Results 1 to 4 of 4
  1. #1
    Join Date
    Sep 2002
    Posts
    511

    Talking

    I have a R-22 walk-in cooler at the camp that isn't keeping temp.
    The temp now is 50 and I need to get the temp down to 35to 38.
    The compressor is pot type and air cooled.

    There is no t-stat,it runs off a dual pressure control.

    There are three cold pack style gravity evaporators with one TXV feeding them.

    The suction pressure is 25 psig and I can't seem to get the king valve to break free on the high side.

    It has a receiver and sight glass and the sight glass was'nt clear when I first looked at the unit.

    I tried to clear the sight glass by adding refrigerant slowly,but the glass would clear and after awhile it would go back to the way it was when I first looked at it with barely any in the sight glass.

    The pressure switch's are set at cut-in=30psig and cut-out=10psig.
    Two out of the three cold packs(evaps)where froze and one was not.
    The suction pressure was remaining steady at 25 psig .



  2. #2
    Join Date
    Jun 2004
    Posts
    182
    Think about your suction pressure, why is it at 25 psig? That is 1F saturation temperature for a 35 box, that is now at 50. Sounds like an awful high temperature difference across that evaporator. Look at the evaporator superheat. I have to believe you are starving there. (low charge, restriction etc.)

    Ask yourself why is the suction pressure so low. Also why is your pressure control set so low for a medium temperature application?

  3. #3
    Join Date
    Oct 2004
    Posts
    2
    Wondering that myself! The pressure switch is set up for a
    low temp. application. But the temp. that I am trying to maintain is 35-38 degrees which I know is a medium temp. box. thought maybe the pressure switch was set where it is in order to run the 3 cold pack evaporators with no fan at a lower temp.

  4. #4
    Join Date
    Sep 2002
    Posts
    511
    To clear up any confusion,....Shae-dog and I work together and are talking about the same problem.

    we were thinking that the pressure switch was set low because of the type of evaporators used in this setup.

    In this case gravity coils.but also thinking low on charge as basser mentioned earlier.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event