Results 1 to 9 of 9
  1. #1
    Hello again everybody,

    My Frigidaire freezer (upright) Model #FFU13F9GW is cycling. I hear the compressor try to kick on then shuts off after about 10 seconds. This has been happening for several weeks now. The freezer is still cold, but my guess is the compressor may be going. What could be the problem?

    Thanks for the help.

    Jim

  2. #2
    Join Date
    Dec 2000
    Location
    Flat Rock, NC
    Posts
    463
    Sounds like your overload is weak or maybe relay is bad. Install one of Supco co. 3n1 start kits and you should be OK. Do this soon as compressor failure is certain without repair. This part is available at any supply house for under $40

  3. #3
    Thanks for the advice. I just turned the freezer off, as I noticed it wasn't keeping cool any longer. The compressor is hot, as expected. I have worked on refrigerators, before with my dad, but that was years ago. Can you give me a bit more detail on how to do this? Anything would be great.

    Thanks again!

  4. #4
    Join Date
    Feb 2004
    Location
    puerto rico
    Posts
    121
    hello friend; CODGY has reason put 3n1 start kit and check if the has a fan between compressor for some paper in the fan. clean the condenser too.

  5. #5
    Hi again,
    I found a 3-in-one start kit here...
    http://www.repairclinic.com/0081.asp?RccPartID=965237

    This part does not currently exist in the freezer. There is only 1 fan, inside the freezer, not one near the compressor.I looked at the condenser, and it looks pretty clean. Also, there is only the compressor overload and a defrost thermostat by the compressor.

    Do I install the 3-in-one in replace of the compressor overload?

  6. #6
    Join Date
    Feb 2004
    Location
    puerto rico
    Posts
    121
    hello friend ;the you take (low,and high pressures,do you do the (efficient prove) to the compressor.

  7. #7
    I'm sorry but I don't understand. Are you saying that I use the 3-in-1 to replace the compressor overload?

    Thanks again.

  8. #8
    Join Date
    Nov 2001
    Posts
    244

    freezer

    Does the freezer have a capacitor? If so check that.iF you got the replacement relay try replacing see if that does trick. Check amps.draw.Watch out that its not under warranty as if you mess with it they might not honor it.Usually its 5yrs on sealed system, but some manufactors have given 10yrs. If not under warrenty check pressures, its properly the compressor.ed0612

  9. #9
    Join Date
    Jul 2003
    Location
    ALABAMA
    Posts
    230
    I agree with codgy. If that doesn't fix it you have a compressor that may need replaced. That 3in 1 kit will make it that simple troubleshooting job for you.

    If you don't know where the csr terminals are ask your dad.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event