Page 3 of 3 FirstFirst 123
Results 27 to 34 of 34
  1. #27
    Join Date
    Sep 2004
    Location
    Kansas City, Kansas, United States
    Posts
    13,832
    wow!!!!!!!!!!!!!!!!!!1
    i am not a blue oval fan!
    that being said!
    I have dozens of 30 series chillers.
    30rb, gxr 30 anything?
    screws, recips and scrolls.
    I really have not had many problems????

    Maybe this one was built on a friday??
    I WILL SELL WORK,GENERATE BUSINESS, GO GET NEW CUSTOMERS!
    YOU SHUT THE HELL UP AND QUIT RUNNING YOUR MOUTH!

  2. #28
    Join Date
    Apr 2007
    Location
    uk
    Posts
    185
    It looks as if the fan motor may be twisting trying to overcome static pressure. The photo showing the fan sections is that some sort of enclosure around the top of the unit.

  3. #29
    Join Date
    Sep 2004
    Location
    Kansas City, Kansas, United States
    Posts
    13,832
    no they do not have enclosures. they look pretty new, looks like nicro channel cond coils!!
    Most likely ICE!!!
    lots of ICE! lol

    Quote Originally Posted by Gibbo View Post
    It looks as if the fan motor may be twisting trying to overcome static pressure. The photo showing the fan sections is that some sort of enclosure around the top of the unit.
    I WILL SELL WORK,GENERATE BUSINESS, GO GET NEW CUSTOMERS!
    YOU SHUT THE HELL UP AND QUIT RUNNING YOUR MOUTH!

  4. #30
    Join Date
    Apr 2007
    Location
    uk
    Posts
    185
    If you look at the 2nd last photograph there is clearly some sort of enclosure behind the fan cowlings.

  5. #31
    Join Date
    Sep 2004
    Location
    Kansas City, Kansas, United States
    Posts
    13,832
    still not eein it???????????


    Quote Originally Posted by Gibbo View Post
    If you look at the 2nd last photograph there is clearly some sort of enclosure behind the fan cowlings.
    Attached Images Attached Images  
    I WILL SELL WORK,GENERATE BUSINESS, GO GET NEW CUSTOMERS!
    YOU SHUT THE HELL UP AND QUIT RUNNING YOUR MOUTH!

  6. #32
    Join Date
    Apr 2004
    Posts
    566
    chucks of ice/snow causing problem.

  7. #33
    Join Date
    Aug 2006
    Location
    Central Indiana
    Posts
    215

    Frown condensor motors

    Has any one experienced condensor fan motor failures on these 30rba units? We have a 250 and a 125 and have lost about 12 motors. Failure mode is always bearing failure which then causes rotor to stator grounding. Motors cannot be greased and have no thrust bearings. Any replys would be helpfull.
    Thanks. Mike

  8. #34
    Join Date
    Oct 2010
    Location
    Baton Rouge, LA
    Posts
    1,113
    I feel that if I have to replace 2 fan motors, 3 sensors, and a plastic fan blade in one year on a 5 year old unit it is a piece of junk. Which is what I usually find on Carrier Air cooled chillers. Not to mention having to have a 10 page error code dictionary to find out what T331 means. Can't the screen just say Liquid line sensor failure.
    If you're too "open" minded, your brains will fall out.
    Artificial intelligence is no match for natural stupidity.

Page 3 of 3 FirstFirst 123

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event