Page 2 of 2 FirstFirst 12
Results 14 to 19 of 19
  1. #14
    Join Date
    Oct 2009
    Location
    new jersey
    Posts
    246
    Quote Originally Posted by cliamatecontrol View Post
    been installing ttv series units for years. had two with bad txv, now one with a half cloged distributor, all in a year. is it just me or everyone having issues with these machines?
    how do tou know the txv is bad how did you know distributor is clogged

  2. #15
    Join Date
    Oct 2009
    Location
    new jersey
    Posts
    246
    the carrier booklet chart says it should work with water temp down to 30 bet water in temp at 40 it shut off on cold water/low flow sensor water pressure in 28psi out 20psi

  3. #16
    i have installed and worked on climate master and (carrier) which is made by climate master for ten years there have been some problems fp sensors ging bad are the most common problem. the problems with the olds ones were they would sweat and get water inside to the tick and short it out. the new ones are sealed and dont have that problem. have had a few problems with txv's when they went to a different manufacture but they went back and havent had any more bad ones. all in all i have installed almost all manufacture of geo-thermals and like the climate master the best. there tech support is the best out there.

  4. #17
    dave sulz
    Regular Member

    Join Date: Oct 2009
    Posts: 4
    the carrier booklet chart says it should work with water temp down to 30 bet water in temp at 40 it shut off on cold water/low flow sensor water pressure in 28psi out 20psi


    make sure you have cut the fp1 sensor on the board to cause the lower freeze protection.

  5. #18
    Join Date
    Oct 2009
    Location
    new jersey
    Posts
    246
    Quote Originally Posted by mikeduncan View Post
    dave sulz
    Regular Member

    Join Date: Oct 2009
    Posts: 4
    the carrier booklet chart says it should work with water temp down to 30 bet water in temp at 40 it shut off on cold water/low flow sensor water pressure in 28psi out 20psi


    make sure you have cut the fp1 sensor on the board to cause the lower freeze protection.
    i think that is j3 jumper

  6. #19
    jw3 and fp1 are the same when cut it drops the temp

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event