Results 1 to 4 of 4
  1. #1
    Join Date
    Oct 2009
    Posts
    2
    Post Likes

    Exclamation Carrier 30gt liquid chiller.

    Circuit A of the above mentioned chiller is not working but the circuit B is working properly.In quick testing the thermisters are ok and the EXV is opening and closing and the compressors are also ok but in normal working the EXV is not opening.The alarm indicate code 68.
    pls suggest a solution??

  2. #2
    Join Date
    Feb 2003
    Location
    Wichita Ks
    Posts
    1,525
    Post Likes
    quick testing of the sensors only show open or shorted sensors. They could be way off. you need a manual for this chiller and study it.

  3. #3
    Join Date
    Jun 2009
    Location
    Florida
    Posts
    540
    Post Likes
    Quote Originally Posted by abdul majeed View Post
    pls suggest a solution??
    Call a qualified tech.
    Low Pressure Forever!

    If you know heavy metal, you can work anywhere-Dave Andreson

    Anchors Aweigh my boys, Anchors Aweigh!
    Farewell to foreign shores, We sail at break of day. Through our last night on shore, Drink to the foam. Until we meet once more. Here's wishing you a happy voyage home!

  4. #4
    Join Date
    Oct 2009
    Posts
    2
    Post Likes
    The inlet connection in circuit A and circuit B of the cooler has an oil and refrigent leaking due to rust.Can we change the cooling head or the inlet pipe to solve this problem or is there any other measures.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Related Forums

Plumbing Talks | Contractor MagazineThe place where Electrical professionals meet.
Quality Home Comfort Awards