Results 1 to 4 of 4
  1. #1

    Vulcan SG4 Convection Oven

    This thing is driving me crazy! I hope someone can help. Long story short, at times it runs for hours without fail. But when it does fail to operate correctly, one of two things occur. Most times when it fails, its calling for heat(heat light on/no ignition light off), but there is no spark and the heat relay doesnt energize. Other times, less often, the heat light comes on and the no ignition light is on. The sensorr(read 21 ohms at room temp) has been replaced, and L1/H2 has been bypassed on the power level switch, but no change. Any help would be appreciated as the cooks are sharpening their knives! Thanks

  2. #2
    Join Date
    Dec 2005
    Location
    Memphis, TN.
    Posts
    823
    Don't shoot me here cause I have never had my hand in one of these but I have had a similar problem...I found that the (if there is one) exhaust fan in the electrical compartment area would heat up and quit causing the thing to trip out on a safety condition...took me forever to figure that thing out!

    Finally had to go to the job while none of the cooks were there for safety sake...those ladies are pretty dang accurate with those knives!!!

    Give that a shot and see...Good luck on that one it sounds like your in for a good time. Sorry I couldn't be of more help.


    CW.
    "I don't care what you could get it off the net for, they wont warranty it and neither will I"!

    And if you don't like my "flat rate up front pricing" try and negotiate the price on that big mac you just bought pricing is exactly the same method!

  3. #3
    Join Date
    Mar 2008
    Location
    Over the river and through the woods
    Posts
    116
    I would start by checking that the wiring is all good and tight, especially the 16 gauge wires that the factory wire nutted together. Check the plugs for good connections while you are at it. Next thing I would check is flame rectification and clean the flame sense rods. Is the heat relay coil energized?? Check the convection blower fan switch and related wiring. I dont have the schematic in front of me but I believe the energy path to the heat relay goes thru the conv. fan 'sail' switch before the heat on relay. Check your schematic, I believe the heat 'on' light is energized thru the temp control board and the red 'ig fail' light is thru the ignition mod. The red light comes on before ignition then goes off after flame rectification. So if the heat on light is lit but the red ig fail light doesnt light you do not have power to the ignition board. Long story short, check your wiring, follow the schematic and victory will be yours! I just spent 4 hours on one tracing wiring issues. Good Luck!!

  4. #4
    Join Date
    Feb 2008
    Location
    ga
    Posts
    80
    Check to see if the centrifical switch is closing in the blower . It is a normally open switch that closes when then the motor runs .This is a common problem. This feeds the spark module to produce flame.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event