Results 1 to 5 of 5
  1. #1
    Join Date
    Dec 2008
    Posts
    4

    Issues with Carrier Furnace

    Hey Folks:

    Quick question for you. I am in need of some Carrier furnace troubleshooting. I am typing from work so don't have the model number.

    I came home and turned on my A/C last night. This was the first time I used it in two months. The A/C came on, but the blower never turned on in the furnace. I went down to look at the furnace and I can tell the A/C is working because the side of the furnace is freezing cold. I looked at the LED and noticed flashing LED light. The error I was receiving was 12.

    I decided to turn on the heat to see if the problem only existed with the A/C. The furnace (both the blower and the gas ignition) turned on for roughly 2-3 minutes and then shutdown. The error code this time was 33. The weird part was even though the blower was on there was no air coming from any of the vents. I checked both upstairs and downstairs.

    I am at loss of what the problem might be. Does anyone have a clue on how I can further diagnose the problem?

    Thanks,

    Claude

  2. #2
    Join Date
    Aug 2006
    Location
    Wyoming
    Posts
    304
    Call a professional service company. This site is not a diy site.

  3. #3
    Join Date
    Dec 2007
    Location
    Cedar Grove, Wi-Sheboygan
    Posts
    1,582
    Do you have the Infinity controller ? could be a matter of a wiring issue between the stat and the furnace, especially if the blower turned on when you switched to heat mode, but didn't run when in cooling mode. If you have the infinity controller there shouldn't have been any issue with wiring since there is a simple pig tail connection from the controller to the furnace and the frunace would then be controlled thru the controller and not the dip switches on the furnace itself.

    Call your installer and have him check the wiring from the stat to the furnace, something isn't right IMO !!

  4. #4
    Join Date
    Dec 2008
    Posts
    4
    Thanks DanW. Sorry about posting this here. I just read the rules and realized I should have put this in this forum, since it is not what its purpose is. I will take a look tonight. If I cannot figure it out I will call someone.

    Its a 13 year old furnace, high effiency. I noticed that blower will only come on once then shut down and if I put the thermostat to ON it still does not start the blower.

    Claude

  5. #5
    Join Date
    Dec 2002
    Location
    Toledo, Ohio, United States
    Posts
    12,921
    Twilli says good luck as Twilli isn't a Carrier dealer....http://www.youtube.com/watch?v=AYaVqdujy6g
    Last edited by Twilly; 07-31-2009 at 06:22 AM.
    No Heat No Cool You need Action Fast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event