Results 1 to 11 of 11
  1. #1
    Join Date
    Aug 2008
    Location
    levittown, pa
    Posts
    63

    Confused Bryant heat pump blowing fuse

    Hello all, I haven't been around here for a while and I have problem. I have a bryant air handler that is popping the fuse when the signal goes to the outdoor. This happens just after the icon stops blinking on the stat. I didn't have a light with me so I didn't look outside yet. Just looking for ideas because I never ran into this yet it only does this on a call for heat or cool not on e heat or fan.

  2. #2
    Join Date
    Feb 2009
    Location
    New England
    Posts
    190
    you have short in the condensor wire

  3. #3
    Join Date
    Mar 2002
    Location
    Richmond, Virginia
    Posts
    4,264
    If you are blowing the LV fuse, check the press. sw. leads at the outdoor unit for chafing.
    There is nothing more frightful than ignorance in action....Mark Twain

  4. #4
    Join Date
    Feb 2009
    Location
    New England
    Posts
    190
    are you talking about the breaker or the fuse on the circuit board?

  5. #5
    Join Date
    Aug 2008
    Location
    levittown, pa
    Posts
    63
    Yup, your probably right about the chafing of the pressure switch wire. It sucks I didn't have a light but its at my in laws house so they can wait til tommorrow, its all the other people that can't!! How many posts do you need to become pro? Thanks

  6. #6
    Join Date
    Feb 2009
    Location
    New England
    Posts
    190
    15

  7. #7
    Join Date
    Aug 2008
    Location
    levittown, pa
    Posts
    63
    The 5 amp auto fuse. Its a FV bryant that I put in 6 years ago.

  8. #8
    Join Date
    Dec 2007
    Location
    Ohio
    Posts
    2,875
    Outdoor contactor could be bad also. Sounds alot like the same symptoms that the York Units had when they got a bad batch of contactors at the factory.

    Every call for contactor blew the indoor fuse....
    I need a new signature.....

  9. #9
    Join Date
    Feb 2009
    Location
    New England
    Posts
    190
    HVAC Pro brought up a good point because ive seen that happen on a bryant evolution before

  10. #10
    Join Date
    Feb 2009
    Location
    New England
    Posts
    190
    and a bad contactor would over amp that fuse too but you might be lucky enough to hear it hanging up

  11. #11
    Join Date
    Aug 2008
    Location
    levittown, pa
    Posts
    63
    Man you guys are quick!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event