Page 2 of 2 FirstFirst 12
Results 14 to 18 of 18
  1. #14
    Join Date
    Apr 2015
    Location
    GTA
    Posts
    27
    Post Likes
    Thread Starter
    Quote Originally Posted by Poodle Head Mikey View Post
    Is this a piston compressor or a screw compressor?

    A 1º difference across the chiller's evaporator is very low - especially with a warm floor. <g>

    The machine isn't Doing anything -

    Is the compressor loaded?
    Is the amp draw 50% of FLA or higher?
    Was the brine flow 'adjusted correctly' previously and now is wide open / 100% of the pump capacity?

    24 lb. suction is about -10-12º F. If the leaving brine is +19º F. that is a 30º chiller approach temp. - which blows. <g> The leaving water should be closer to 0º, and preferably a little lower, with that suction pressure.

    Has the machine ever faulted on low oil pressure?
    Has anyone been adding oil to the machine?

    PHM
    ----------
    These are great questions that I can try to find out. I have an amp meter, but Im not allowed to open any part of the machine to measure the draw. The machine is a piston compressor.
    Oil levels are checked every 2 hours, and oil is added when needed. Im not sure how often oil is added to the compressors.

  2. #15
    Join Date
    Apr 2015
    Location
    GTA
    Posts
    27
    Post Likes
    Thread Starter
    These are great questions that I can try to find out. I have an amp meter, but Im not allowed to open any part of the machine to measure the draw. The machine is a piston compressor.
    Oil levels are checked every 2 hours, and oil is added when needed. Im not sure how often oil is added to the compressors.

  3. #16
    Join Date
    Apr 2015
    Location
    GTA
    Posts
    27
    Post Likes
    Thread Starter
    The sensor was just tested though, at least the paperwork indicates that

  4. #17
    Join Date
    Nov 2011
    Location
    East Side
    Posts
    4,527
    Post Likes
    could be any number of things. compressor capacity, low refrigerant charge, oil logged evap., brine system problem.

    if the sensor is actually good and is always reading around 29ppm, you may have a leak.

  5. #18
    Join Date
    Jul 2012
    Location
    WA
    Posts
    2,327
    Post Likes
    Head pressure is pretty high. What type of condenser and what’s the ambient temp? What’s head pressure normally run on this system? Is it a DX or pumped liquid recirc?

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Related Forums

Plumbing Talks | Contractor MagazineThe place where Electrical professionals meet.