Results 1 to 10 of 10
  1. #1
    Join Date
    Jan 2005
    Location
    boston area
    Posts
    14
    Post Likes

    York yciv “dc bus imbalance”

    Anyone have this one?they don’t list it in the book.checked all line voltages and load side fuses,all good. Restarted and she ran like a champ. Facility has had service side power issues,but none today(that anyone is aware of)
    Would incoming 3 phase issues generate this. Have had it before. Found blown 5amp fuse on suppression board,but not this time.thoughts?

  2. #2
    Join Date
    Nov 2015
    Posts
    164
    Post Likes
    Check the resistors over front side of vsd there the balance resistors
    There's a certain ohm reading I'd have to look at manual but if they look over heated or one ohms different then other change

    Sent from my SM-G950U using Tapatalk

  3. #3
    Join Date
    Jun 2003
    Location
    Gulf Coast
    Posts
    244
    Post Likes
    Quote Originally Posted by airwaveman View Post
    Anyone have this one?they don’t list it in the book.checked all line voltages and load side fuses,all good. Restarted and she ran like a champ. Facility has had service side power issues,but none today(that anyone is aware of)
    Would incoming 3 phase issues generate this. Have had it before. Found blown 5amp fuse on suppression board,but not this time.thoughts?
    What manual are you looking in?
    My manual has it.

  4. #4
    Join Date
    Jan 2013
    Location
    United Kingdom
    Posts
    65
    Post Likes
    Check the DC buss isolation board also it has three wires, plus dc, minus dc and common that steps down the signal into the Logic VSD board, it is a small board with 3 resistors on , mounted just above the cap bank and to the right. Check the DC buss voltage too if this is low it may be a mis-fire on the input SCR's , check the 3 pairs of wires that output on the trigger board J1, J2 and J 3 and make sure they go to the correct SCR.
    If you have a scope or power analyser then look at the Voltage and current waveform. Voltage should be normal sinusoidal and current will be the double camel hump.Volt Screen.pngCurrent Screen.png
    Not sure if i have attached pics correctly, let me know

  5. #5
    Join Date
    Apr 2016
    Location
    Maryland
    Posts
    244
    Post Likes
    >> DMAX I wonder who taught you to rig like that ? HMMM...

  6. #6
    Join Date
    Nov 2015
    Posts
    164
    Post Likes
    Quote Originally Posted by CHILLERSVCMAN View Post
    >> DMAX I wonder who taught you to rig like that ? HMMM...
    Definitely not my foreman
    That YR no body in the branch had split apart
    Had to call resolute which is the old Chicago compressor shop to get details and even parts Part Center didn't have some Orings I needed
    By the way that was Northeast Middle


    Sent from my SM-G950U using Tapatalk

  7. #7
    Join Date
    Apr 2016
    Location
    Maryland
    Posts
    244
    Post Likes
    Well too bad I am not there anymore . I have taken apart screw compressors before . The YRs were nothing but problems from day one . Remember BAC and ALL the overtime on that " BOAT ANCHOR " ?

  8. Likes Dmax liked this post
  9. #8
    Join Date
    May 2018
    Posts
    2
    Post Likes
    Good day I can send you the YCIV troubleshooting guide

  10. #9
    Join Date
    Jan 2013
    Location
    United Kingdom
    Posts
    65
    Post Likes

  11. #10
    Join Date
    May 2018
    Posts
    2
    Post Likes
    Thank you

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Related Forums

Plumbing Talks | Contractor MagazineThe place where Electrical professionals meet.