Page 1 of 3 123 LastLast
Results 1 to 13 of 28
  1. #1
    Join Date
    Apr 2012
    Location
    Chicago, IL
    Posts
    117
    Post Likes

    Fan shrouds icing, taking out fans.

    I got an account that's a distributor of dairy products. It only has two isolated, small office areas that have comfort heating/cooling, and then a bunch of unconditioned warehouse space. Scattered about are a drive-in dock cooler, and several large walk-in freezers and coolers. I have an ongoing issue with the freezers, particularly the basement and 1st floor freezers, and particularly the Russell evaps; the fan shrouds and fan guards develop a thin layer of ice, and start locking up fans. It's due to the humidity, no doubt, and also because of the tight clearances on the Russells. I've told the guys if they see a fan stop spinning, to tap the fan guard, and this is usually enough to get the fan going, but the place goes through evap fan motors like candy if they don't catch them in time. There's also times where you can hear fans hitting the ice that'she forming, and it's. . . Unpleasant. And hard to explain to the customer. I've told the owner to add dehumidifiers to the common areas, and he added a couple small ones, which helped. I also told him to keep the doors closed as much as possible. Nothing has solved the issue. Is there something else that can be done to the evaps themselves that I'm not aware of? It's not a function of improper defrost -- the coils are fine, the clocks are programmed properly, and there's no ice on the floors, ceiling, or product really. Any suggestions appreciated.

  2. #2
    Join Date
    Oct 2011
    Location
    Harrisburg, NC
    Posts
    951
    Post Likes

    Fan shrouds icing, taking out fans.

    Just forms on the guards? From inside the guard or outside?


    Sent from my iPhone using Tapatalk

  3. #3
    Join Date
    Apr 2012
    Location
    Chicago, IL
    Posts
    117
    Post Likes
    Thread Starter
    Inside the plastic guards, but the the real problem is the sheet metal shroud that the tips of the blades clear. There's not much clearance there, and ice firms around it. I don't know if it continually forms through the cycle or is just a magnet for moisture from defrost, but it's only the Russell evaporator that have this issue.

  4. Likes GavinJuice liked this post
  5. #4
    Join Date
    May 2014
    Location
    Bay Area California
    Posts
    13,750
    Post Likes
    Since the coils are clean, and the ice is forming on the shrouds and guards, maybe the air is moving too quickly through the coil.

    Might want to try something on one box, put on some blades with less of a pitch. That will increase the TD, and help the coil to catch the moisture. Probably lose a bit of capacity with the increased TD, so try it on the least critical box just to see what happens.

    You never know, might get lucky.

    The other thing, of course, is to be in the box and monitor the full defrost cycle. Just to make sure that the terminations and all are working proper. But if it is happening in ALL freezers, then it is likely more of an environment issue.

  6. #5
    Join Date
    Apr 2012
    Location
    Chicago, IL
    Posts
    117
    Post Likes
    Thread Starter
    Thanks, yeah, I may have to try that. It is happening to all the Russell Evaps in 3 different freezers. As for the defrost cycles, I did have an issue on one where ice built up over time on the enclosed tube sheet where heaters didn't touch, burying the defrost termination switch AND the fan delay switch. This caused a whole other issue of ice on the floor, wall, ceiling, and fan blades due to excessive defrost and fans coming on immediately, but since then, all of the defrost ops have been good as far as I've seen.

  7. #6
    Join Date
    May 2014
    Location
    Bay Area California
    Posts
    13,750
    Post Likes
    The only other thing that comes to mind is an interesting problem I had on a blast freezer one time. One small part of the coil didn't want to defrost. So on each defrost cycle that small patch would grow just a tiny bit more. I fixed it by moving the pan heater out of the factory clips that were holding it.

    Which makes me wonder if putting an additional single heater right at the front of the pan would help clear the ice on the shroud and guard.

    But I'd try the fan blade thingy first. It's fast, easy, and inexpensive.

    I might even turn in the TEV stem one full turn, just to see the results. That would tend to make part of the coil colder, even though the coil would be feeding less. Once in awhile, you just stumble across an easy fix by being a bit unconventional.

  8. #7
    Join Date
    Nov 2012
    Location
    San Pedro, California, United States
    Posts
    26
    Post Likes
    I second the idea on the pitch..
    How new are the evaps?
    Can you call the manufacture and get the proper motor RPM and pitch size?
    Possible a few have been changed improperly over the years..

  9. #8
    Join Date
    Apr 2012
    Location
    Chicago, IL
    Posts
    117
    Post Likes
    Thread Starter
    All the Russell evaps that are giving us trouble are 8 years old. They're 4-fan and 6-fan evaps, and they all have trouble. It's unlikely that the blades are different -- I've changed several of the motors myself, with exact aftermarket replacements, and just reused the blades. The fan blades are all the same, but all of the fans pretty much do this at one time or another, so it's not a select few. One time on a PM, one of the 6-fan evaps in the basement freezer had 5 fans stuck! I used my pocket screwdriver and an 11-in-1 to bang on the guards and pushed the blades to start the motor, and, luckily, all the fans were able to break free from the thin ice and start back up.

  10. #9
    Join Date
    May 2014
    Location
    Bay Area California
    Posts
    13,750
    Post Likes
    Got another idea for you. On coolers, not freezers, I have seen such large gaps between the drain pan and the bottom of the evap coil that the fans have picked up and slung water out into the box. Which makes me wonder if you are getting too much air going under the evaporator instead of through the finned coil.

    Those were on coils from Heatcraft, yours may be constructed differently. Just seems like that for whatever reason, the moisture in the air is not sticking to the coil, rather just passing through.

  11. Likes The Turtleman liked this post
  12. #10
    Join Date
    Apr 2012
    Location
    Chicago, IL
    Posts
    117
    Post Likes
    Thread Starter
    Quote Originally Posted by BBeerme View Post
    Got another idea for you. On coolers, not freezers, I have seen such large gaps between the drain pan and the bottom of the evap coil that the fans have picked up and slung water out into the box. Which makes me wonder if you are getting too much air going under the evaporator instead of through the finned coil.

    Those were on coils from Heatcraft, yours may be constructed differently. Just seems like that for whatever reason, the moisture in the air is not sticking to the coil, rather just passing through.
    That could very well be it, thanks. I'll take a look at that next time I'm out there. Moisture always seems to find a way, and the fact that the stats are set to -20 doesn't help -- not that the capacity isn't there, it's just with the amount of door opening that goes on daily, these evaps get a lot of work and have to perform a lot of dehumidification beyond the scope of normal designs.

  13. #11
    Join Date
    Aug 2002
    Location
    Southold, NY
    Posts
    12,318
    Post Likes
    To short of a fan delay can allow moisture to be drawn off the coil.
    Too long of a defrost can creat steam.
    Start with the fan delay. A little air gap between the klexon and blower.

  14. Likes VTP99, Juan Madera liked this post
  15. #12
    Join Date
    Oct 2011
    Location
    Harrisburg, NC
    Posts
    951
    Post Likes
    Quote Originally Posted by pecmsg View Post
    To short of a fan delay can allow moisture to be drawn off the coil.
    Too long of a defrost can creat steam.
    Start with the fan delay. A little air gap between the klexon and blower.
    Crap you beat me.

    If fan delay kilixon is on a run or mounted too close to the distribution tubes, it can cause the fans to come on too soon as well.


    Sent from my iPhone using Tapatalk

  16. #13
    Join Date
    Aug 2002
    Location
    Southold, NY
    Posts
    12,318
    Post Likes
    Quote Originally Posted by CRussell1975 View Post
    Crap you beat me.

    If fan delay kilixon is on a run or mounted too close to the distribution tubes, it can cause the fans to come on too soon as well.


    Sent from my iPhone using Tapatalk

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Related Forums

Plumbing Talks | Contractor MagazineThe place where Electrical professionals meet.