Results 1 to 4 of 4
  1. #1
    Join Date
    Dec 2016
    Posts
    3
    Post Likes

    Confused Munchkin 399M issue

    One of our Munchkin 399M boilers runs continuously and never gets above 150 degrees. Fan speed 8,000 rpm, condensate drain was partially plugged but has been cleared and no error codes. Should I be looking at the circuit board which modulates the fire rate or a dirty heat exchanger?

  2. #2
    Join Date
    Mar 2013
    Location
    Billington Heights, NY
    Posts
    7,716
    Post Likes
    is this a new issue? what has changed since it worked correctly last?
    Experience - knowing when to get the hell out of the way and plug your ears. "Don't be a sissy. Turn it on!"
    Poodle Head Mikey - "the world is well populated with the unknowing and the uncaring and the stupid."

  3. #3
    Join Date
    Dec 2016
    Posts
    3
    Post Likes
    It had been cycling great achieving 180 degrees without issue. I believe its the circuit board so I unplugged the air switch and it kept running with no error codes.

  4. #4
    Join Date
    Jun 2012
    Location
    Northern NV
    Posts
    342
    Post Likes
    Fireside of the heat exchanger on these can get plugged up and having had a plugged condensate trap would lead me to suggest you find a service tech that has had experience with doing this particular service.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Related Forums

Plumbing Talks | Contractor MagazineThe place where Electrical professionals meet.
Comfortech 365