Results 1 to 10 of 10
  1. #1

    LG minisplit issue

    Just wanted to get an opinion on an LG Im working on. the customer calls about a week ago and says his minisplit is not heating. I get there and he has a picture on his camera of the outdoor unit iced up so bad it had ice coming out of the louvres. it wasnt defrosting obviously. I cant remember what the pressures were (I can hardly remember what I had for lunch). They seemed OK though, because by the time I got there it was in the upper 40s outside and most of it had melted off. To sum it up the board wasnt calling for a defrost. I told him Id order a board and be back. Talked to him today (going out there in the morning) and he said it happened once more since i was there and now that its 15 degrees outside its working like a champ. Anyone else have intermittent problems like this with these stupid things if so what seemed to be the resolution.

  2. #2
    Join Date
    Aug 2003
    Location
    Florida
    Posts
    50
    Lets make sure it was ice. Could it been frost? From the temperature outside you stated you know more about ice then me but ice is clear not white. Do you think from the pics clear or white? The coil will get at least 80-90% frost and even more if it's as cold and a little bit more humid outside. Could be O.K.
    This probably sound dumb to you but I,m from Florida. Did you adjust the charge when you we out?

  3. #3
    Join Date
    Oct 2008
    Location
    Coming to a town near you soon
    Posts
    774
    Did he clean the filter when he realized it wasn't heating?

  4. #4
    I checked the charge and it was fine, didint see any need for adjustment. The filter was clean, that was the first thing I checked. It was definately ice. The customer said it did it once more after I was there and its been fine ever since. The only thing I could think of is an intermittent problem in the board itself (defrost control). Does the defrost control work off the OD/coil temp delta or a timer or both?

  5. #5
    Join Date
    Aug 2003
    Location
    Florida
    Posts
    50
    Sounds like a "goddamn board " issue to me!!

  6. #6
    Join Date
    Aug 2003
    Location
    Florida
    Posts
    50
    Quote Originally Posted by adamhvac View Post
    I checked the charge and it was fine, didint see any need for adjustment. The filter was clean, that was the first thing I checked. It was definitely ice. The customer said it did it once more after I was there and its been fine ever since. The only thing I could think of is an intermittent problem in the board itself (defrost control). Does the defrost control work off the OD/coil temp delta or a timer or both?
    The board is a demand defrost control. If coil reaches a determined temperature or delta "T" thru coil it goes into defrost. But they smart little guys and it also is controlled by indoor temperature demand.
    Is it not much heat or no heat at all when they call? Or are they looking for ice............

  7. #7
    Its wasnt heating well when he first called in and there was ALOT of ice on the OD unit. Well I got the board so I guess Ill put it on and see what happens. The guys an aviation engineer so hes constantly asking questions and standing over my shoulder. I just love working for engineers! Not that it makes me nervous when they look over my shoulder, Ive got nothing to hide, but damn its annoying.

  8. #8
    Not to mention working on this Jap Crap! Minisplits SUCK! There I feel better.

  9. #9
    Join Date
    Aug 2003
    Location
    Florida
    Posts
    50
    Quote Originally Posted by adamhvac View Post
    Its wasnt heating well when he first called in and there was ALOT of ice on the OD unit. Well I got the board so I guess Ill put it on and see what happens. The guys an aviation engineer so hes constantly asking questions and standing over my shoulder. I just love working for engineers! Not that it makes me nervous when they look over my shoulder, Ive got nothing to hide, but damn its annoying.
    Eat a can of baked beans the night before..........

  10. #10
    Join Date
    Oct 2008
    Location
    Coming to a town near you soon
    Posts
    774
    Quote Originally Posted by adamhvac View Post
    Its wasnt heating well when he first called in and there was ALOT of ice on the OD unit. Well I got the board so I guess Ill put it on and see what happens. The guys an aviation engineer so hes constantly asking questions and standing over my shoulder. I just love working for engineers! Not that it makes me nervous when they look over my shoulder, Ive got nothing to hide, but damn its annoying.
    When I have customer stand over my shoulder I go into hyper salesman mode. This usually makes them go hide or they end up buying something.

    I know what you mean about the "engineers". If their so smart why dont they fix the d@mn thing.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event