Results 1 to 5 of 5
  1. #1
    Join Date
    Jun 2006
    Location
    Omaha,Ne
    Posts
    43

    UniTrane Fan-Coil

    Hello and thanks in advance for any help. Working on a unit that is Mod#FCDB020 it was installed 9-06 and worked fine till about a month ago. There was construction going on in the building and with all the dust I assumed coil was dirty took it apart cleaned coil put back together CS is 47 CR is 63 and DB of room is 78 with 60% humidity.Pulled water screen out removed very little debri water is being treated but looks rusty.Dont know where to look next thought about pulling coil and replacing we have a spare in shop.Thanks again

  2. #2
    Join Date
    Aug 2000
    Location
    USA
    Posts
    4,990
    You have low chilled water flow. Plugged strainer, control valve not opening, etc.
    Your poor planning does not constitute an emergency on my part!!!!

  3. #3
    Join Date
    Jun 2006
    Location
    Omaha,Ne
    Posts
    43
    Thanks for your reply. Took apart control valve was clean and made sure it opened all the way also cleaned the flow regulator. I thought about checking the water flow going into the coil by timing it going into a container and then checking it coming out of the coil if that makes any sense to you and seem to be worth trying tomm to see if its in the coil or the rest of the system.

  4. #4
    Join Date
    Aug 2000
    Location
    USA
    Posts
    4,990
    Is your cw pump on a vfd?
    Your poor planning does not constitute an emergency on my part!!!!

  5. #5
    Join Date
    Jun 2006
    Location
    Omaha,Ne
    Posts
    43
    No its not its a constant flow

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event