Results 1 to 5 of 5
  1. #1
    Join Date
    May 2007
    Location
    LA
    Posts
    26

    RV Duo-therm; Penguin model by Dometic

    Folks AC went down on RV.

    Two units identical problem on both; Run and cool for about 15 minutes, kick off.

    On arrival found hot compressor, checked thermal OL on compressor and verified closed. only two safeties, this one and freeze stat. no HPCO or LPCO.

    Board is open, on an NO relay (both units). Jumped relaly and compr. ran. Cond. fan is running already indicating a call. Data phone cable type stat.; unable to check input. I suspect something in board/stat are holding unit out on temp; not able to find any trouble shooting for board/ or stat on Google, only find install instructions.

    Unable to check charge, no access ports and don't have a piercing valve.

    I cleaned both condensers but suspect this is not the problem. No oil noted around compressor or condenser indicating a leak

    Why would the board hold out the compressor? What is it sensing? Time?

    If let sit, several hours, the units will come back on again. I can't get past why the board and not the compr. thermal OL is tripping??!!??!!

    Thank you, Clay

  2. #2
    Join Date
    Nov 2004
    Location
    Naples, Fla.
    Posts
    1,403
    No schematic?

  3. #3
    Join Date
    May 2007
    Location
    LA
    Posts
    26

    yes there is

    All it shows is the black from the board to the cpr. OL (thermal) parrallel to the start and return on com. This is fed from a NO relay, mounted on the board. This rely is open. I jumped the relay and bumped the the compressor.

    The only other safety is the freeze stat.

    This is a heat pump.

    I appreciate your reply; I'm guessing my lack of response is due to my heading?!?

    If I had listed it by the problem alone I see I would have received many more views and therefor responses.

    Thanks,
    Last edited by clayb1; 09-08-2008 at 11:22 AM. Reason: add info/detail

  4. #4
    Join Date
    Dec 2007
    Location
    East central Indiana
    Posts
    477
    Are the terminals labeled on this NO relay?

  5. #5
    Join Date
    May 2007
    Location
    LA
    Posts
    26

    yes

    com and 5; com is hot (L1) and 5 goes to the OL on the cmpr

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event