Results 1 to 7 of 7
  1. #1

    York air cooled screw

    We are having a problem with the display blank and erratic chiller operation. We can't see anything on the display. Now Chiller will not run at all.

    Model # YCAS0330EC58YFADBXXXXXX42CXXXXXXXXWSAXXBXXXXXXLXXE
    Serial # RDLM003021

    Any thoughts would be much appreciated.

  2. #2
    Join Date
    May 2007
    Location
    Surrey BC
    Posts
    118
    Buy a Trane!

  3. #3
    Join Date
    Aug 2006
    Location
    Mixing oil and fire with a big spoon.
    Posts
    4,255
    check the main circuit breaker...if it is off then perhaps it needs to be turned on...if it is locked out/tagged out or if it is tripped, then do NOT turn it on. otherwise, if this is all of the troubleshooting that you can provide...i would suggest that you call a qualified HVACR company for further diagnosis...we all just want everybody to go home safe.

    good luck.
    my 1st time jumping out of a plane...http://youtu.be/Kv38G0MHsGo

  4. #4
    Check all Jack/ plugs'' ''some wire'' ''some fuse port,,for chiller vibration .
    juan clavell santiago

  5. #5
    Join Date
    Sep 2007
    Location
    Somewhere in the world.
    Posts
    1,595
    Open up swing door check power supply to display disconnect plug wires #10 & #12 there should be 12 volts dc. if not go to power supply board and test power at J6 . You should test and check power suppy fully. As for erratic operation you need display to see whats going on first.

  6. #6
    Join Date
    Nov 2007
    Location
    I am unsure myself
    Posts
    1,116
    Hey Jayguy pretty funny post considering that is my BOSS I am not kidding either. Perhaps you can answer his question for me any help would be much appreciated. PWW its one of your interior boys here i think you know which one.

  7. #7
    Join Date
    May 2007
    Location
    The South
    Posts
    555
    This may be a bit redundant,but if you have no display,and the chiller isn't running,the control power circuit,usually(not always) 120v,may be having a problem.
    There is usually either a line volt to 120 trans,or a dedicated 120 line ,with a fuse or breaker,inside the control panel.Sometimes there is a ups on this circuit too.

    Could be as simple as a fuse/breaker,and maybe not.
    GO DAWGS!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event