Blower Problems, Is This Filter The Cause?
Results 1 to 4 of 4
  1. #1
    Join Date
    May 2007
    Location
    Colorado
    Posts
    101

    Blower Problems, Is This Filter The Cause?

    I have an Amana furnace AMH8 http://www.amana-hac.com/Portals/1/pdf/SS-AMH8.pdf with a VisionPro thermostat (But not the IAQ version)

    I have the thermostat programmed so the furnace blower will run in the ON mode in the mornings whether there is request for A/C or not. (It helps even out temps upstairs, and humidity is not an issue in my area.) I have had the entire system for just a little over a year now. The A/C is Tempstar 14 Seer 2 ton.

    Recently the blower motor has started acting stange. When the thermostat shows the fan should be ON and there is no call for cooling the furnace blower motor will cycle on and off, on and off rapidly. If the thermostat is calling for COOL then the blower in the furnace and the A/C unit outside run like normal and cool fine.

    I would like to use the fan only function, but have reprogrammed the TSTAT to avoid this function for now. I am afraid the current problems will cause premature motor failure.

    I read quite a few threads before starting this one, and have a few observances for you pro's that may help:
    1.) When in normal operation the VisonPro will make a clicking noise before making a change in call. When my VisionPro is in the no cool, fan ON mode and the problem occurs the thermostat is not clicking...so I think perhaps the thermostat is not at fault, or at least it's not calling for fan on then fan off, then fan on, then fan off.
    2.) I have a Cimatec Airscreen 1500. The installing company threw it in as part of my system package. I read threads on hear about this filter and see that many Pro's do not think very highly of this filter. From a homeowners prospective I love it. But all I know is every time I go to change it...its just absolutely disgusting...so it must work good, right? ( I mean this thing looks like someone threw a cat in the return and he got sucked into the filter. ) I know nothing about static pressure, but I was wondering if this furnace has somesort of switch that will stop the fan if it senses too much static pressure. Currently when this issue is occuring the change filter light is not on, and visually the filter looks OK. Not nearly as dirty as I have seen it. I also have never had issues with icing of the indoor coil.
    3.) The best way I can describe the problem is relating to the safety switch on the front panel. Its kinda like someone is taking off the front panel, putting it back on, then taking it off, then on, etc. Although I am sure the front cover is on tight. Also every cause I can think of doesn't explain when the furnace blower works fine in the COOL mode.

    Thanks in advance for any info. Its been over 100 here for the past few days...and I'm sure since my unit is cooling fine that this wouldn't be too high of a priority for my HVAC company. Also, if it's just a simple HO fix I would like to know.

  2. #2
    Join Date
    Mar 2001
    Location
    North Carolina
    Posts
    428
    The problems I have seen with these type of filters is the cause to much restriction and cause most furnaces to cycle on the high limit switch.
    That particular one says it has .13 pressure drop @300 fpm. Which gets worse as it gets dirty. try putting in a standard filter in its place and see if it still cuts off and on.

  3. #3
    Join Date
    May 2007
    Location
    Colorado
    Posts
    101
    Quote Originally Posted by obxtech View Post
    The problems I have seen with these type of filters is the cause to much restriction and cause most furnaces to cycle on the high limit switch.
    That particular one says it has .13 pressure drop @300 fpm. Which gets worse as it gets dirty. try putting in a standard filter in its place and see if it still cuts off and on.
    High limit switch? Is this something that is tripped if there is too much static pressure? If so, why would the unit run fine in cool mode? Is it possible the installing company sold me a size too small? My unit is 2ton outside compressor, 2.5 ton inside evaporator, the filter is 16x25.

    I know the Cimatec company recommends replacing the media once every 90days. I can tell you from experience the filter is very clogged looking after only 30 days. I thought this meant that it was working good.

    As far as your suggestion for a new filter, I will stop and pick one up on the way home from work. Any suggested types, or any to avoid?

  4. #4
    Join Date
    Mar 2001
    Location
    North Carolina
    Posts
    428
    High limit switch is a temperature probe between the heat exchangers that shuts off the burners when the temperature gets to hot, and it is not in play in the cooling mode.

    Just get a standard throw away filter for testing purposes. If the problem goes away with the standard filter then you know that airflow was the issue.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event