Results 1 to 3 of 3
  1. #1
    Join Date
    Aug 2008
    Location
    SW, Va
    Posts
    4

    Old Heat pump runs constantly on "heat"..

    Hi all, first post. I live in an apartment that uses an old, early 80's Lennox 2-stage heat pump. When using this in the winter, it NEVER shuts off. It will reach the desired temp,(the green indicator on the t-stat goes off)but it continues to run. I have to manually cut it off. Looks like the t-stat was changed to a newer unit(still with mercury switches though)

    Any ideas? The electric bill is getting insane.

    Thanks, Vinny

  2. #2
    Join Date
    Apr 2008
    Location
    TEXAS
    Posts
    1,701

    Confused

    apparently you have heat pump that is almost 30 years old. if i were to guess, that would also be your problem. without a thorough going over its impossible to tell. it could be sticky contacts or faulty t stat. does the cooling side work ok?
    "When the people find they can vote themselves money,that will herald the end of the republic" - Benjamin Franklin

    "Government is not reason, it is not eloquence, it is force;like fire, a troublesome servant and a fearful master. Never for a moment should it be left to irresponsible action"- George Washington

  3. #3
    Join Date
    Aug 2008
    Location
    SW, Va
    Posts
    4
    Cooling works okay. It is just the heat side that will not shut off.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event