Weird problem, wonder if there is a second opinion out there please?

Our A/C compressor unit broke and after the outrageous price we were given for a compressor replacement (over $2000), we did some research and found a licensed A/C guy who does weekend work willing to swap it out - we got the parts. He came to the store with us and we purchased the compressor unit today.

The old unit is a Copeland CR42K6-PFV-230 and the new unit is a CR41KQ-PFV-980WB. Sound close enough? The specs on the units seem very similar. We don't need the heater though on the new one so it is left disconnected. Very close physical footprint and it bolted in OK.

He swapped out the compressor unit firstly removing the R22 with a special unit that attached and after evacuating the old R22, attached a vacuum unit, then disconnected the old compressor, re-connected the new one and welded the new pipe-work in. So far so good (apart from a couple of leaks from his welding, which he fixed before starting).

He then put in the R22 in the system (apparently there isn't too much of a scientific way to measure how much went in, although he felt confident it was probably 6 pounds but he had no way of really knowing.

He started up the unit and it started straight away and seemed good. Cool air started flowing into the house and there was a 17 degree variance between house temp and cool air that was in the late 50's. The temp in the house was about 74 to begin and we had the thermostat set to 66 to get it going. After a short while and his last minuted fiddles, the compressor tried to start again- we heard the buzz but the compressor unit would not start. The fan ran, but the compressor did not. So he swapped the capacitor and still no difference. Then he tried a hard start kit - still no good.

Then he measured the compressor unit and told me the internal overload in the compressor was coming on (open circuits right?) apparently to stop the compressor from overload. Weird. Then he evacuated the unit of a little R22 and tried again. Still no good.

After an hour or more he departed saying the compressor was probably bad. Remembering it is brand new, purchased from a reputable local agent of Emerson this seems strange. We agreed to run it for a day and see what happens.

The thermostat inside is set to 69 but reading about 74. We also tried resetting the thermostat and swapping out batteries.

The scenario is that the thermostat seems to be working and starts the fan unit inside to move air around the ducts and the fan on the condensing unit outside periodically starts but blows cold air out not hot, indicating that the compressor is not starting (and we cannot hear the compressor).

So the outside unit periodically starts, runs for a while and then stops (presumably because the overload protection protects the compressor from starting).

The compressor unit draws 16.2 amps running and I was told that the pressure is 210 PSI and the suction side is 60PSI. I do not know what the grade or spec of the coil in the furnace is though (or whether that even matters).

Any experts care to have a stab at what is wrong? We are not sure whether it is the compressor (wrong replacement? - see above model), the A/C guys work, or something else.

Any thoughts are appreciated. Wanted to know whether we are being taken for a ride... and what we should do next.

Thank you very much.