Results 1 to 4 of 4
  1. #1

    EnviraZone Board Issue?

    The circulation fan in my two-zone Honeywell system will not stop operation.

    I have two zones in use, with VisionPro thermostats tied to a EnviraZone Control Panel W8835A1004.

    I've disconnected the fan connection to the EnivraZone and the fan turns off. I've removed both thermostats and let them sit for 15 minutes without batteries, powercycled the HVAC system and then replaced thermostats and the fan operation continues (even with both thermostats set to "OFF" operation).

    I think I need to replace the EnviraZone board. Are there any more tests I should perform before *having a service tech* test the EnviraZone?

    Thanks.
    Last edited by milk_badger; 07-23-2008 at 04:59 PM. Reason: ...clarified my question.

  2. #2
    Join Date
    Aug 2003
    Location
    Lincoln, Nebraska
    Posts
    1,051
    You need a pro with a meter to check this system. The boards are not cheap. Don't just start changing parts, get it done right.

    May want to read the rules again. No DIY on this site.
    Its a good Life!

  3. #3

    Thanks

    Quote Originally Posted by m kilgore View Post
    You need a pro with a meter to check this system. The boards are not cheap. Don't just start changing parts, get it done right.

    May want to read the rules again. No DIY on this site.
    Thanks Kilgore! I'm simply trying to become an educated homeowner and learn a little more about my HVAC system so I can have an intelligent conversation with my Tech. No need to call him out if all I need to do is reset or clear the system if it is something simple as simple as that.

    For example, I'm not a big believer in a $150 service call to change the AA batteries in my thermostat. (I don't have batteries BTW). I'm not a HVAC installer trying to earn a living by learning from the experts on this site. Just trying to be a better consumer. (...see I did read the rules before posting.)

  4. #4
    Join Date
    Jan 2004
    Location
    Lancaster PA
    Posts
    68,565
    Check your set back and recovery programs.
    Set the fan to auto in all of the programs.
    Also make sure the fan setting on the screen is set to auto.
    The System "off" setting has no control over the fan.
    Contractor locator map

    How-to-apply-for-Professional

    How many times must one fix something before it is fixed?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event