Results 1 to 4 of 4
  1. #1
    Join Date
    Jan 2008
    Location
    Egg Harbor Township New Jersey
    Posts
    32

    Delfield Supremacy SRR2-S Side by side Comercial Refrigerator

    I had a call on a Delfield Supremacy SRR2-S Side by side refrgerator. It's throwing A Error Code 7 Box temp went up to 60*. I work for the public school system in my town. Just to let you know This unit had a compressor go on it. My co-worker previously worked on it. He installed a whole new condensing unit on it. Don't know why he did. I would have changed the compressor, drier, and swept the system, acid test etc. He called me over when he installed new unit and he was having problems. No suction pressure. He had a blob of solder in the line that was blocking flow.
    Got that cleaned out. He pulled a vaccum and weighed in the charge of 24 oz of 404A. The unit ran fine. So I went to the call yesterday and the compressor was coming off and on a few times. I felt the top off the compressor, it wasn't that hot to go off on thermal protection. I'm starting to think the board is acting funny in this unit giving false readings? Or still moisture in the sytem still. TXV not a cap tube system. If anybody has a service manual that they can post I would appreciate it.

    Thanks, John

  2. #2
    Join Date
    Jul 2000
    Location
    Guayaquil EC
    Posts
    10,319

    Delfield SSR2S...

    Here's the Owner's Manual which includes info on the Paragon ERC-2 controller you have.

    http://www.delfield.com/?xhtml=xhtml...ds.xsl&doc=ser

    The ERR 7 code just indicates a high temperature alarm. I doubt you have a controller problem. The overload may be tripping due to high pulldown amps.

    Does this unit have a CPR valve...or did it before your colleague replaced the unit?

  3. #3
    Join Date
    Jan 2008
    Location
    Egg Harbor Township New Jersey
    Posts
    32
    Thank you for the reply. I didn't rembeer seeing a CPR valve on the unit. I will double check tomorrow moring It was a last minute call today. I will be back on it in the morning. I didn't see a trouble shooting section, in the manual for the codes. I would like to have for reference. If you have a listing could you post please. Being that I don't have any other literature on the unit. I will post up tomorrow.

    Thanks,John

  4. #4
    Join Date
    Jan 2008
    Location
    Egg Harbor Township New Jersey
    Posts
    32
    Hello, Found unit was not charged properly. I reclaimed the refrigerant. Pulled vaccum and recharged.

    Thanks for replies, John

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event