Results 1 to 5 of 5
  1. #1

    ClimateMaster Geothermal troubleshooting

    Im trying to troubleshoot a Climatemaster ground source geothermal. It is about 10 years old, and a 2 stage unit (2 x 1.5 ton).

    When it calls for first stage, the fan and circulation pump runs, the compressor starts, runs for about 2 minutes, then the compressor drops out (everything else keeps running as long as there's a call for heat), and thus no heat on first stage. It waits a few minutes and trys again a couple more times before it lockout. When second stage kicks in, it works fine (the second compressor runs, fan speeds up, etc).

    When I go into test mode on the control board, I get fault code 4 which is FP1 (water coil freeze protection). The limit setting jumper is clipped, for the closed loop/antifreeze system. I checked the gray wires going to the thermistor, and I get ~16k ohms (or more when running), which is about right by the manual (60*F). The compressor when it does run draws about 3.2 Amps which seems ok.

    Any other things to check before I tell him to call a refrigeration person?

  2. #2
    Join Date
    Jan 2004
    Location
    Lancaster PA
    Posts
    66,808
    Nope, time to make the call.
    Contractor locator map

    How-to-apply-for-Professional

    How many times must one fix something before it is fixed?

  3. #3
    Join Date
    Nov 2001
    Location
    east kansas
    Posts
    8,012
    Call for service. It probably needs it's loop goosed regardless of the problem.
    Beware of advice given by some guy on the Internet.

  4. #4
    Join Date
    Dec 2007
    Location
    oregon
    Posts
    885
    Call a company that has experiance in servicing geo units.
    There a are three things you first look for in trouble shooting a geo unit, water flow, water flow and of course water flow.
    The last thing you do on these things is to put your gauges on them.
    Genius = The guy who can do anything...except make a living!

  5. #5
    Join Date
    Jan 2005
    Posts
    2
    Quote Originally Posted by sprdave View Post
    Im trying to troubleshoot a Climatemaster ground source geothermal. It is about 10 years old, and a 2 stage unit (2 x 1.5 ton).

    When it calls for first stage, the fan and circulation pump runs, the compressor starts, runs for about 2 minutes, then the compressor drops out (everything else keeps running as long as there's a call for heat), and thus no heat on first stage. It waits a few minutes and trys again a couple more times before it lockout. When second stage kicks in, it works fine (the second compressor runs, fan speeds up, etc).

    When I go into test mode on the control board, I get fault code 4 which is FP1 (water coil freeze protection). The limit setting jumper is clipped, for the closed loop/antifreeze system. I checked the gray wires going to the thermistor, and I get ~16k ohms (or more when running), which is about right by the manual (60*F). The compressor when it does run draws about 3.2 Amps which seems ok.

    Any other things to check before I tell him to call a refrigeration person?
    the last one i had do that, was doing it because it was undercharged. you will have to put the gauges on

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event