Page 3 of 3 FirstFirst 123
Results 27 to 31 of 31
  1. #27
    Join Date
    Aug 2007
    Location
    MN
    Posts
    2,677
    nah, never is

    After removing the venting and verifying it was clear, I noticed a whistle behind the inducer, I think when Jerry replaced the transition last yr, he didn't use enough RTV, I redid the RTV seal and it quieted down, so we should be good to go now, 10 days and no callback

    No water leaking out of the cold header so I'm sure that is not the cause, but never know I have seen them go without seeping water for a few yrs then let loose and we get water on the blower deck. If that happens they will get a new HX out of the 10 yr P&L.
    You can't fix stupid

  2. #28
    Join Date
    Dec 2002
    Location
    Rochester, MN
    Posts
    5,305
    Ok, I think the cold header issue was 4 years ago, also the modular on the blower went out at the same time.

    Did you guys cover the 2nd call? I know mom was kinda upset that the first call didn't take care of the issue,

  3. #29
    Join Date
    Aug 2007
    Location
    MN
    Posts
    2,677
    Quote Originally Posted by mayguy View Post
    Ok, I think the cold header issue was 4 years ago, also the modular on the blower went out at the same time.

    Did you guys cover the 2nd call? I know mom was kinda upset that the first call didn't take care of the issue,
    absolutely! We would never charge for a callback of the same issue. (Only a doctor can get away with that )
    You can't fix stupid

  4. #30
    Join Date
    Dec 2002
    Location
    Rochester, MN
    Posts
    5,305
    Good.. I know she was grumbling about how in the last house, 24 years with the Williamson never had an issue, just a belt.. and the Trane put in '99 never had a call..

    I told her, that's why I talked you guys into the 10 years p/l warranty, things are not made like they used to, then she kinda quiet down.

  5. #31
    Join Date
    Aug 2007
    Location
    MN
    Posts
    2,677
    Quote Originally Posted by mayguy View Post
    Good.. I know she was grumbling about how in the last house, 24 years with the Williamson never had an issue, just a belt.. and the Trane put in '99 never had a call..

    I told her, that's why I talked you guys into the 10 years p/l warranty, things are not made like they used to, then she kinda quiet down.
    She heard an echo then cause I said the same thing!
    You can't fix stupid

Page 3 of 3 FirstFirst 123

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event