Results 1 to 6 of 6
  1. #1

    New 410A system freezing up

    I am a new tech in training and have a problem at my own house. My 410a system keeps freezing up. Filter is new. suction pressure is about 85 which seems low and head pressure is about 230 which seems ok. Super heat goes all over the place from 6 to 16. do you think I have a refrigerant restriction? Any help is greatly appreciated. Thanks.

  2. #2
    Join Date
    Oct 2013
    Location
    Alberta Canada
    Posts
    329
    Better look closer at that 85. Maybe google a pt chart for 410.

  3. #3
    Its freezing because your coil is below 32 degrees. 85 is pretty low.

  4. #4
    Join Date
    Jul 2014
    Location
    Boca Raton, FL
    Posts
    38
    Looks like your options are low evap airflow, low on charge, or restriction/faulty txv.
    Can you get more readings like indoor temp, ambient, liquid line temp and suction line temp? Is the metering device a txv?

  5. #5
    Join Date
    Aug 2006
    Location
    Florida (some where) way-south
    Posts
    230
    Dude, it's R410a not R22.
    Check your pressures, it's low.

    Like the other Guys said use PT chart and check it and charge it properly.

  6. #6
    Join Date
    Jul 2014
    Location
    Boca Raton, FL
    Posts
    38
    Quote Originally Posted by fix_it_dude View Post
    Dude, it's R410a not R22.
    Check your pressures, it's low.

    Like the other Guys said use PT chart and check it and charge it properly.
    Ya sorry ignore my post...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event