Results 1 to 4 of 4
  1. #1
    Join Date
    Apr 2011
    Location
    michigan
    Posts
    170

    Imperial 4 Port Gauge Problems Model 644-CCJ

    Does anyone have a set of imperial 4 port gauges model 644-ccj that has had problems with them?? I have a set that will not hold a good vacuum below 400 microns, I can pull down a split system to 160 microns, but as soon as I shut off the pump, vacuum jumps to 440 microns, tried pulling just on a recovery cylinder, same problem. Sometimes after I valve off the vacuum port then re open the vacuum port it will not pull a vacuum through the manifold. I am ordering a rebuild kit for the valves hopeing that will solve the problem. Any other ideas?? How about different manifold suggestions?? Looking at a Ritchie Titan 4 port set.

  2. #2
    Join Date
    May 2013
    Location
    STP, MN
    Posts
    126
    Read this thread: http://hvac-talk.com/vbb/showthread....ac-pump-set-up

    And do that, either SLC's setup or Mike19's on page 3. Problem solved.

  3. #3
    Join Date
    Jan 2005
    Location
    Akron
    Posts
    1,064
    Quote Originally Posted by Toddbrewster View Post
    Does anyone have a set of imperial 4 port gauges model 644-ccj that has had problems with them?? I have a set that will not hold a good vacuum below 400 microns, I can pull down a split system to 160 microns, but as soon as I shut off the pump, vacuum jumps to 440 microns, tried pulling just on a recovery cylinder, same problem. Sometimes after I valve off the vacuum port then re open the vacuum port it will not pull a vacuum through the manifold. I am ordering a rebuild kit for the valves hopeing that will solve the problem. Any other ideas?? How about different manifold suggestions?? Looking at a Ritchie Titan 4 port set.
    Todd,
    My contact information is in my profile. Get me some contact information so we can discuss getting them repaired. How new are they?

    Jim Bergmann
    Director New Product Development
    Imperial Tools
    JLB,

  4. #4
    Join Date
    Apr 2011
    Location
    michigan
    Posts
    170
    ok will do, been busy have not had time to get back on here, i will try to get back to you shortly. thank you

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event