Results 1 to 6 of 6
  1. #1

    Trane XR80 "Check Igniter" Code

    I have a Trane XR80 that's around 3-4 years old. I woke this morning and noticed a 6 degree difference between the thermostat setting and actual temp (set at 68, actual 62). Felt the vents, nothing.

    I looked at the furnace and noticed the lights flashing twice (lockout). I cycled power twice within 30 seconds as suggested. The unit powered up. Steady flashing lights (call for heat) for about 60secs and then I heard what sounded like the igniters trying to work for about 3 seconds. The unit sounded like it powered down but I think the blower was still going. I checked the light and it was flashing 9 times (check igniter).

    Next step is CALL A TECH i'm sure. Any idea what would cause this? It worked great yesterday. I noticed that the unit has a 20 year warranty on the heat exchanger and wondered if this fell under that. Any advice would be appreciated.

  2. #2
    Join Date
    Jan 2004
    Location
    Lancaster PA
    Posts
    67,928
    You need a service tech.

    Ignitor and HX aren't related.
    But you still could have a 5 year part warranty from the installing contractor.
    Contractor locator map

    How-to-apply-for-Professional

    How many times must one fix something before it is fixed?

  3. #3
    Join Date
    May 2007
    Location
    somewhere between heaven and hell
    Posts
    957
    If you have a bad ignitor that doesn't fall under 20 year warranty of the heat exchanger. Yep better call someone out there to fix it cannot really give out to much info on here. Shouldn't be very bad fix if it's what I think it is.

  4. #4
    Thanks for the info. Now to find out who the heck installed this thing. I bought the house 2 years ago (unit was installed 1-2 years before).

  5. #5
    Looks like the ignitor is the problem. Anyone here able to look up the replacement ignitor part #? My xr80 model number is TUD060C936K2.

    Thanks in advance.

  6. #6
    Join Date
    Jun 2001
    Location
    Louisville, KY
    Posts
    12,189
    Quote Originally Posted by cysquatch View Post
    Looks like the ignitor is the problem. Anyone here able to look up the replacement ignitor part #? My xr80 model number is TUD060C936K2.

    Thanks in advance.
    This site is not for DIY. Please don't ask for this type of assistance.
    Perhaps you should have read the instructions before calling.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event