Results 1 to 9 of 9

Hybrid View

  1. #1
    Join Date
    Dec 2007
    Posts
    1
    Post Likes

    armstrong heat pump problem

    i am a service tech with a problem with a 12yr old armstrong heat pump the condesor coil freezes up from time to time gauge presures are l=25 h = 315 could it be the expansion valves if so wich one is bad condesor or evaprator ive changed the defrost bd thinking this may be the problem mostly in the past i worked on orfice systems not txv.
    Last edited by discount; 12-09-2007 at 11:52 AM.

  2. #2
    Join Date
    May 2000
    Location
    Indianapolis, IN, USA
    Posts
    35,332
    Post Likes
    Sorry, you've come to the wrong place for DIY help. Need to find someone qualified to be working on a heat pump.

  3. #3
    Join Date
    Dec 2007
    Posts
    1
    Post Likes
    Defrost thermostat.

  4. #4
    Join Date
    Jun 2007
    Location
    Round Rock
    Posts
    3,841
    Post Likes
    Sounds like a restriction somewhere. Could be bad metering device or trash floating around in the system.

  5. #5
    Join Date
    Jan 2007
    Location
    Granger, IN
    Posts
    49
    Post Likes
    i am surprised your 12 year old armstrong was installed with TXV.

  6. #6
    Join Date
    Mar 2007
    Location
    Quebec, Canada
    Posts
    56
    Post Likes
    I'm also surprised that a service tech doesn't know which tx valve to check. NO DIY.

  7. #7
    Join Date
    Jan 2004
    Location
    PA
    Posts
    69,779
    Post Likes
    What would you check, if it was a piston metering device.

    Picture the refrigerant systems flow in your mind.
    Contractor locator map

    How-to-apply-for-Professional

    How many times must one fix something before it is fixed?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Related Forums

Plumbing Talks | Contractor MagazineThe place where Electrical professionals meet.
Comfortech365 Virtual Event