Results 1 to 3 of 3
  1. #1
    Join Date
    Jul 2006
    Posts
    4

    Flaky Bryant Truesense filter monitor

    I have a Bryant dual fuel evolution system with an aprilaire media filter (2400). System has been installed for about a year. I've been checking the filter status and it changes daily from 0 - 30% used. I understand the daily static pressure check it does at 1PM, but do not undertand why it fluctuates so much. We are not doing anything to the ducts - all remain open.
    Is this typical of this feature?
    Thanks

  2. #2
    Join Date
    Jul 2006
    Posts
    4
    Update- this thing is still acting weird. I went ahead and changed the media filter (Aprilaire 2400) even though the highest the evolution filter monitor ever got was 50% used. It had been in 15 months and was dirty.

    So after changing the filter yesterday, I reset the filter monitor on the evolution control and it read 0%. Today after the 1PM static pressure test the filter monitor jumped to 80% used. Any ideas? Or should I just ignore it?
    Thanks

  3. #3
    Join Date
    Feb 2003
    Location
    Huntsville,AL
    Posts
    4,125
    use your eyes--
    if you see dirt, change
    harvest rainwater,make SHADE,R75/50/30= roof/wall/floor, use HVAC mastic,caulk all wall seams!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event