Results 1 to 7 of 7

Thread: T-stat issues

  1. #1
    Join Date
    Jul 2007
    Posts
    56

    T-stat issues

    well its not so much of the t-stat but only on heat mode / em heat will it flicker off and back on again after about a minute of running. I tried a different t-stat and its doing the same thing so thats what led me to think that wasnt the problem.

  2. #2
    Join Date
    Mar 2004
    Location
    Illinois
    Posts
    6,959

    Call a pro...

    and have it checked.

  3. #3
    Join Date
    Jul 2007
    Posts
    56
    i was hoping to use this as a learning exp. for myself incase i ever run into it with a homeowner

  4. #4
    Join Date
    Jan 2004
    Location
    Lancaster PA
    Posts
    68,308
    If your a tech, you have enough post to apply for pro membership.

    Questions like this are best asked in the pro forum. Thats where you'll get answers to all sorts of solutions for many different situations.
    Contractor locator map

    How-to-apply-for-Professional

    How many times must one fix something before it is fixed?

  5. #5
    Join Date
    Jul 2007
    Posts
    56
    ok thanks

  6. #6
    Join Date
    Jul 2007
    Posts
    56
    so how long does it take to get access? i sent an email a few days ago

  7. #7
    Join Date
    Sep 2001
    Location
    kalamazoo,mich
    Posts
    2,174
    It takes them a couple days to review your information.
    Have you hugged the Earth today?
    Donny Baker rules

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event