Results 1 to 5 of 5
  1. #1
    Join Date
    Sep 2003
    Location
    Western PA
    Posts
    1,354

    Reznor unit heater won't light

    Hello guys,
    I have a Reznor model# SSC250-6-s-MV. It has two burner compartment and only one will light. It uses a Johnson Controls G67BG-5. I've only swithed to the commercial side of the trade four months ago so I'm green. How do I troubleshoot the control? I do have 24volts to it. At the unit there are two spare pilot burners. Thanks for any help.

  2. #2
    Join Date
    Dec 2004
    Location
    Chicago area
    Posts
    1,439
    Please refine your question. Do you mean there are two burners and only one lights, or there are two seperate burner sets, meant to stage?

    If two total burners, then clean the burners. If two stages of burners, fired independantly, then check for 24 v between ths and ground on the igition module of the non working burner set. If no power check for power at w2 and common if 24 v, then the tstat is calling, if no 24 v, then no call is present. If there is power to w2 and not to the 2cd stage ignition module, then you have a open limit. overtemp, pressure switch etc..
    Need more of your findings to be of more help

  3. #3
    Join Date
    Feb 2007
    Location
    Dallas, Tx.
    Posts
    572
    if it single stage with two burners, and only one is lighting, I wouldn't watch it too closley unless you are not too attached to your eyebrows!
    mike

  4. #4
    Join Date
    Nov 2003
    Location
    Boston
    Posts
    600
    Quote Originally Posted by targetman View Post
    At the unit there are two spare pilot burners. Thanks for any help.
    Ask yourself "why there are spare pilot burners on site?"

    Check the pilot orifices. Could be clogged and need replacing.
    Edited by powerhead on more than one occasion

  5. #5
    Join Date
    Sep 2003
    Location
    Western PA
    Posts
    1,354
    Sorry for the confusion about the burners. It has two seperate burner compartments. Each with its own gas valve, flue, pressure switch, ignition control and so on. I worked on it this morning. I just swithed ignition controls and the non lighting burner section lit. Also noticed that the draft inducer motor for taht section is very loud. Parts on order.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event