Results 1 to 4 of 4

Thread: need advice

  1. #1

    need advice

    I'm a beginner tech. Working with Carrier 38 TE 2.5 ton split system (R-22). It wasn't in use 2 years. Minimum of freon left in. Compressor was working with a little vacuum on suction. I've pressurized the system with nitrogen - ok. Stable presure. After that I've avacuated it until 25 in Hg. Holding fine. And then I've charged the system with liquid freon through high side port by eye (I don't have a charging scale). The system pressure now is 70 psig. When I turn the system on compressor starts, but in 3 sec it stops. It repeates in 3 min.
    Any ideas, please.

  2. #2
    Join Date
    Mar 2004
    Location
    Illinois
    Posts
    6,959
    Wrong forum...being moved.

  3. #3
    Join Date
    Mar 2004
    Location
    Illinois
    Posts
    6,959
    Okay...moved.

    How about a little info on your experience and the company you work for? (Not the name of it) Do they have a senior technician?

    I can tell you this though, if you are genuinely a tech, you need to apply for pro membership, once approved you can post this in the pro forums where we can give you guidance and help. In the open forums we can't give you much of either.

  4. #4
    Join Date
    Sep 2006
    Posts
    41
    Go back to your text books you got when you took the course in refrigeration
    You should not be working on equipment yet without supervision IMO.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event