Page 1 of 3 123 LastLast
Results 1 to 13 of 38
  1. #1
    Join Date
    Aug 2006
    Location
    NJ
    Posts
    3

    Fuses keep blowing out!

    I have a rooftop HP aprox 10 yrs. It keeps blowing fuses. I've cleaned the condenser & evap coils, changed the contacter, changed the cap & added a hard start. all pressures are good. Sometimes it will run for 2 months and sometimes for 2 hrs. depending on the weather. Should I replace the compressor or the whole unit?

  2. #2
    Join Date
    Nov 2006
    Location
    New Hampsha'!!!
    Posts
    284

    Thumbs up

    you need a service tech!
    dont worry what people think, they dont do it often

  3. #3
    Join Date
    Jun 2007
    Posts
    23
    Loose fuses, poor connections @ disconnect?
    Are they just blowing on hot days?



    ____________________________________________
    We're not satisfied, until you're not satisfied

  4. #4
    Join Date
    Apr 2007
    Location
    Rossland, B.C.
    Posts
    95
    Check supply wiring size, length of run and breaker type / size.

  5. #5
    Most likely loose fuses in the disconnect. Replace disconnect to be safe and double check amps, wiring, make sure it is not short cycling. OR just cut a piece of copper the same size as the fuse and ....

  6. #6
    Join Date
    Dec 2003
    Location
    Nevada
    Posts
    1,815
    Quote Originally Posted by njcontractor View Post
    Most likely loose fuses in the disconnect. Replace disconnect to be safe and double check amps, wiring, make sure it is not short cycling. OR just cut a piece of copper the same size as the fuse and ....
    ........you'll find what is blowing them guaranteed!
    I have heard that described as an extreem slow blow fuse!!
    Quote
    “Engineers like to solve problems. If there are no problems handily available, they will create their own." Scott Adams

    "We can't solve problems by using the same kind of thinking we used when we created them."
    Albert Einstein

  7. #7
    Join Date
    Jun 2002
    Location
    Dacula, GA
    Posts
    12,955
    Besides checking the amps check your voltage at the contactor and on the electrical panel. You could have low voltage.
    "I could have ended the war in a month. I could have made North Vietnam look like a mud puddle."
    "I have little interest in streamlining government or in making it more efficient, for I mean to reduce its size. I do not undertake to promote welfare, for I propose to extend freedom. My aim is not to pass laws, but to repeal them. It is not to inaugurate new programs, but to cancel old ones that do violence to the Constitution."
    Barry Goldwater

  8. #8
    Join Date
    May 2007
    Posts
    141

    Intermittent fuse life !!

    You mentioned, depending on the type of weather !! What type of weather ??
    I'll assume, hot humid, maybe raining !! (maybe not) For the sake of arguement - I'll continue !! In my opinion, secure the power off, remove all access doors, very carefully inspect all wiring, devices. Check any place the wires come in contact with the cabinet surfaces, look for rub throughs, any type of black carbon tracking, is sure sign of a fault. Use a quality Ohmeter to test all wiring, devices. If a Meg-ohmeter is available, test all high voltage conductors. You memtioned a hard start kit, so it is single phase, don't meg- ohm the start components, only the motor windings and conductors. Also test the evap and condenser motors, same rule applys. With the disconnect open, test the power wiring from the disconnect to the unit, again do not meg ohm small components, only the power wiring. Be sure you have the correct type of fuses. Dual element, time delay type, that are new, always change them out in pairs, even if one tests O.K. Is there a time delay in the circuit to keep the compressor from short cycling, not on the T'stat side, but last in line to the compressor, if not add one. Measure the voltage and amperage of all motors - compare to nameplate. With a hard start kit, the compressor should start right up quick. Measure the inrush current if your meter has that option. Be sure the fuses are of sufficient size, be sure all electrical connections are tight. Inspect the compressor motor terminals, and other motors if applicable. The refrigeration system needs to operate properly as well. Correct system pressure are required, and can cause high current if all is not well. Be sure to Lock Out the Disconnect when performing all of the work. Saftey first. These are the first areas to check when attempting to locate such a problem, just my opinion !!

  9. #9
    Join Date
    Jun 2007
    Posts
    23

    Talking

    Quote Originally Posted by njcontractor View Post
    Most likely loose fuses in the disconnect. Replace disconnect to be safe and double check amps, wiring, make sure it is not short cycling. OR just cut a piece of copper the same size as the fuse and ....
    that's funny and scary. would you recommend ACR or Type M.

  10. #10
    Join Date
    Sep 2002
    Location
    Boise Idaho
    Posts
    1,032
    those copper pipes are called "no blow" fuse and I have removed many


    matt

  11. #11
    Join Date
    Oct 2001
    Posts
    6,966
    make sure all your covers are on the contactors...an ark on closing could blow the fuses.is it just one at a time or are you coming up on 2 blown fuses each time.if your 460V 3 phase moisture around the blocks will cause a jump across phases and blow a fuse.could be just as said here a different style fuse to take that locked rotor draw on start...it is 3 phase your working with there?
    "when in doubt...jump it out" http://www.youtube.com/watch?v=U1qEZHhJubY

  12. #12
    Join Date
    May 2007
    Location
    Aurora, IL
    Posts
    123
    I've had issues here and there with power strikes (not lighting hits) into the main feed to my building which has caused units to go down pretty quick due to fuses in the disconnect blowing out. Not every phase though, sometimes just one of the phases from ComEd.

  13. #13
    Join Date
    Dec 2006
    Location
    Middle Tennessee
    Posts
    11,347

    *

    Quote Originally Posted by clgman View Post
    You mentioned, depending on the type of weather !! What type of weather ??
    I'll assume, hot humid, maybe raining !! (maybe not) For the sake of arguement - I'll continue !! In my opinion, secure the power off, remove all access doors, very carefully inspect all wiring, devices. Check any place the wires come in contact with the cabinet surfaces, look for rub throughs, any type of black carbon tracking, is sure sign of a fault. Use a quality Ohmeter to test all wiring, devices. If a Meg-ohmeter is available, test all high voltage conductors. You memtioned a hard start kit, so it is single phase, don't meg- ohm the start components, only the motor windings and conductors. Also test the evap and condenser motors, same rule applys. With the disconnect open, test the power wiring from the disconnect to the unit, again do not meg ohm small components, only the power wiring. Be sure you have the correct type of fuses. Dual element, time delay type, that are new, always change them out in pairs, even if one tests O.K. Is there a time delay in the circuit to keep the compressor from short cycling, not on the T'stat side, but last in line to the compressor, if not add one. Measure the voltage and amperage of all motors - compare to nameplate. With a hard start kit, the compressor should start right up quick. Measure the inrush current if your meter has that option. Be sure the fuses are of sufficient size, be sure all electrical connections are tight. Inspect the compressor motor terminals, and other motors if applicable. The refrigeration system needs to operate properly as well. Correct system pressure are required, and can cause high current if all is not well. Be sure to Lock Out the Disconnect when performing all of the work. Saftey first. These are the first areas to check when attempting to locate such a problem, just my opinion !!

    clgman you need to watch what you post in a non pro forum!

    you might get someone seriously injured if they do what you explain!



    .
    Last edited by Airmechanical; 07-12-2007 at 03:51 PM.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event