Results 1 to 7 of 7
  1. #1
    Join Date
    Mar 2003
    Location
    NY
    Posts
    2,152

    Distech's tech support?

    Does it exist? Has anyone had any good experiences with it? Many of you might find this hard to believe but I get much better support from Trane.

    I have a very small job with 2 controllers, an ECP-500 and an EC-Display. Neither work properly. The EC-Display does not 'write' values to constants on the ECP-500 and the ECP-500 outputs just stop working on occasion. I am not sure where the problem is, but their tech support leaves a lot to be desired. If you call the factory they tell you to call the distributor. I called the distributor today and was told that I should call back in 'several' hours because the support guy was already on the phone with a customer. I e-mailed Distech's tech support and received a a cute reply stating that my request for support had succeeded and they would respond shortly. That was several hours ago. Tomorrow is another day.

    I am also in the middle of another job with approx 50 ASCs that are a little flaky so I am a little nervous about the ECP-500s that I need to finish this job and complete the cutover from the existing system. If all of these ECP-500s are this unreliable and no help from tech support I will be in a lot of trouble on this job.

    Is there a secret to getting tech support from this outfit? Should I send these controllers back and try another vendor? Do you find these controllers to be unreliable?

    As a note, these were not purchased from Engenuity so I don't feel that I should bother them for tech support. I am sure they would be helpful.

  2. #2
    Join Date
    Mar 2007
    Posts
    24
    Call Distech back, on the phone, no emails, and tell them your distributor will not provide you with tech support in a timely manner, and insist that they help you. Don't be a jerk, just be persistent. They will help you but they try to get the distributors to address the problem first, and they would rather deal with the distributor that the contractor or end user.

  3. #3
    Ask for Maurice and try and wait. If not, Sabatino might be able to help. Other than that the rest ain't worth $hit. You'll get stupid curt responses to your emails if you send it.

    Say it's an emergency and can no longer wait.

  4. #4
    Has Teck support improved?
    Intelli-Building = Less Stress, commissioned with diligence!

  5. #5
    Join Date
    Mar 2003
    Location
    NY
    Posts
    2,152
    Yes, I haven't tried to call them lately but they seem to fix known problems quickly and they now have an e-mail notification system that they send out each time a 'patch' is published. Less problems with the controllers lately too.

  6. #6
    Join Date
    Jan 2005
    Posts
    47
    I second dapper on this one.

  7. #7
    Join Date
    Jul 2007
    Location
    Sacramento, CA
    Posts
    250
    Well I going to chime in on this one. I installed 65 ECC-VAVS distech controllers on a job nad had the follwoing problem come up. We use the Counterclock rotation to close the dampers, and we encounter the when the VAV's lost power to the device then it would reset itself back to factory default and we would have to reload the APB file and reset all the parameters in the device, this went on for about a month and at the time we had distech involved in this whole process. There answer was to update the APB to the latest version, which we did. NO HELP. then after we got them to remote into the system and see for themself waht was occuring, they determind that the configuration by using counterclockwise rotation was screwing up the programming of the device. It was apporx. 3 months before we got the Updated APB file to correct this problem, but in my opion I think that it is a patch jiob and not really corrected. I found another glitch with these same VAV's in that when your "WC" is above 1" reading at the VAV it will revert back to 0 reading and default to nul reading, this again has caused a headache.
    The other issue was that a pluging for the RTU installed into Lonmaker with LNS version 3.21 and not 3.22 running cause a failure in the rtu configuration.

    I have talked to all the TECH persons at Distech and Dapper you are corrrect that easy fix are there but complicated fixes or plugin issue elude them.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event