Results 1 to 11 of 11
  1. #1
    Join Date
    Mar 2006
    Posts
    1,025

    thermopile operatiom

    Yesterday i was looking a a southbend convection oven. They would say oven would heat to temp and sometimes the pilot would go out.

    Seems everything on its been replaced. I checked the mv at the valve and had between 600 and 700. When i would turn on the thermostat it would drop to around 300mv and as it would heat the reading would drop. Saw it down to 223 before the thermostat would satisfy.

    This this normal. Its a new valve. Thermostat is 3 months old. Orfice is clean.
    You can't kiss death without it kissing you back. Death is a passionate kisser.


  2. #2
    Join Date
    Oct 2008
    Location
    mid-Tennessee
    Posts
    700
    Can you post a model number? You've got me curious now. I 've never seen a convection oven (or a standard oven) that uses a thermopile. Just deck ovens.

    The pilot flame's heat output is quantitative. With NO load on the thermopile, it can achieve peak voltages. When the thermostat closes and energizes the main burner valve, more current is demanded from the thermopile, so the voltage drops to about the point that you said. I usually see a SUSTAINED voltage under load at around 230-250mVDC. It should not slowly drop from there. If it does, then the pilot valve will eventually not have enough power to keep it open. I've seen this occur many times on fryers. Sometimes it merely needed a simple pilot flame adjustment. Other times I had to clean the pilot burner.

    If this is happening while you're reading the voltage directly from the thermopile output terminals, then it's likely a weak pilot. I'd first remove & clean the pilot. Check it again afterwards. If it's the doing the same thing, access the pilot gas adjuster on the combination valve. Turn it out some (CCW) to feed more gas to the pilot burner.

    Wile you're working on it, I recommend also checking all of your connections through the tstat, the hi limit (if it has one) and at the combination valve. Any loose or corroded connections -OR- resistance through the tstat contacts presents a significant electrical barrier for current flow when being pushed by a mere couple-a-hundred millivolts.

  3. #3
    Join Date
    Jul 2007
    Location
    Beautiful, Philadelphia, the City of Brotherly Love!
    Posts
    1,089
    Can you see the thermocouple when the oven is on? Is is possible the gas pressure is dropping causing the flame to shrink or could it be disrupted causing the flame to move away from the thermopile?
    “You don't get paid for the hour. You get paid for the value you bring to the hour.” Jim Rohn

  4. #4
    Join Date
    Dec 2012
    Location
    Illinois
    Posts
    289
    The last couple years of southbend range ovens did away with the gas tstat and robertshaw type safety valve and now use a ?3 in 1? I think valve. Tstat is electric (pilot duty) and its a milivolt operator in the mini combination gas valve.

    I think the thermopile is a good improvement, that should be a fairly easy environment for a t-pile. Problem is it uses a kinda special new mini gas valve. But we all have experienced the growing pains with southbend's "engineering improvements". Lol

    EC and attic are right on for troubleshooting. Always pay attention to pilot strength when other burners kick on. That can show a supply or pressure issue before you even take the time to get your manometer.

  5. #5
    Join Date
    Oct 2008
    Location
    mid-Tennessee
    Posts
    700
    Thanks CFESAmasterEGSR. Not doing field work anymore so I'm out of the loop. Where I work at, there's a few remnant TS11 PSVs, but mostly BASO PSVs (Vulcan). Combination valves simply aren't on stand-alone convection ovens. So...Southbend is always experimenting.

    Like AtticAce mentioned, gas pressure certainly could be an issue as well if they have a failing line regulator or other supply pressure issues.

    Something I'd discovered only last year that I never knew -

    We All know combination valves have a regulator built in. What I never realized until recently is this: In their typical design, the PILOT isn't regulated by it. Only the main burner. The pilot is raw pressure (from source) that's feeding the combination valve.

    So...operating pressure of a combination valve might be set for 4"WC for the main burner, but the pilot is LINE pressure...whatever that may be (hopefully <7 and 13>"WC).

    I'm j-u-s-t sharing here. Years of service work and I'd never learned that....

  6. #6
    Join Date
    Dec 2012
    Location
    Illinois
    Posts
    289
    Again, great info EC.

    Two additions,

    As I remember checking out the valve southbend is using, it is a combination valve but I don't believe it has a regulator section, straight flow to burner when energized. I do not remember if it had a pilot adjustment on it or not. I would guess it did but am not sure.

    EC. I'm sure you know this but just to clarify for others reading this.

    A NORMAL combination gas valve has a pilot adjustment needle valve. The pilot is unregulated as EC said, but the flow can be controlled by the pilot adjustment needle valve. It's usually under a Philips head screw with very short threads. Very close to where the pilot tube comes out of the valve.

    Just info for reference for anyone that may stumble across this thread.

    Thanks everyone.

  7. #7
    Join Date
    Jun 2013
    Location
    South East US
    Posts
    94
    The reason your millivolts or (microamps if a thermocouple) are dropping too low after running for a while is you have a flue-ing problem, and you are not combusting properly near the pilot in the combustion chamber. I'll bet you dollars to doughnuts the color of the thermopile goes from cherry red at startup to dark when at high temp. Things to check: make sure you are getting proper fluing operation: smoke test in the front of the comb chamber, and at the flue outlet in the rear riser. Make sure unit is level or at least tilting slightly down in the front. Is the hood system on and functioning? Make up air running? Open outside doors in the kitchen and retest- change anything?

  8. #8
    Join Date
    Dec 2008
    Location
    In the country in NE Kansas
    Posts
    75
    Already covered but I'd check incoming gas pressure while burners are on, also check while all other gas equipment on that gas line are under load (make sure the gas line is large enough to feed all of the equipment), clean/adjust the pilot, and make sure the calibration on the oven is close (never seen this problem on an oven but see it all the time on fryers). Had one a few weeks ago that was tripping the high limit, they never told me they had to push the little red button before relighting the pilot.

  9. #9
    Join Date
    Dec 2012
    Location
    Illinois
    Posts
    289
    Gsxrmike-

    Great point! On fryers or conveyor ovens (stuff with a hi limit) you have to keep that in mind. There are some hi limits out there that are auto reset. I had a fryer with an auto reset hi limit doing the exact thing. But they never had to reset the hi limit so that never got mentioned. Turned out the night cook was cranking the temp control up all the way to be able to "cook faster". So it was like a 400 deg max on the control, but it was off by 20 deg hot so it would swing up to the 420 deg range and trip the 425 deg hi limit. Lol. Took like 3 trips out to finally discover that piece of the puzzle.

    Good times!

  10. #10
    Join Date
    Dec 2008
    Location
    In the country in NE Kansas
    Posts
    75
    Yeah I love those calls, mine was for an Asian lady who had all Mexican cooks. The communication between all of us was a strain. Took me 3-4 trips and several phone calls before I got the owner to get the cooks to admit they had been having to reset the high limit. I had her take the grease temp and it was almost 400°F but only set at 375°F. I had her turn it down to 350°F and it hasn't gone out since.

  11. #11
    Join Date
    Jun 2013
    Location
    South East US
    Posts
    94
    In these cases, I've been known to stabilize the oil temperature at 360 degrees, and recalibrate the thermostat to be at it's max setting on the dial. I might substitute an old dial that has the markings worn off if necessary. Problem solved and everyone is happy. The people that want 350 degrees know to max it and go down a little, and the 400 degree folks can max it out to their hearts content.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event