Page 2 of 2 FirstFirst 12
Results 14 to 19 of 19
  1. #14
    Quote Originally Posted by jim bergmann View Post
    I have not noticed it being slow. I have run one side by side with a bluvac and they were neck and neck, less the resolution.
    may I ask why you guys stopped selling them for awhile while everybody else was still offering them.?by the way I do own the 552 and I like it very much.

  2. #15
    Join Date
    Aug 2010
    Location
    Florida
    Posts
    251
    Quote Originally Posted by jim bergmann View Post
    I have not noticed it being slow. I have run one side by side with a bluvac and they were neck and neck, less the resolution.
    FWIW, on my test rig, the 552 is considerably slower than the BluVac. For example, a jump of 1000 microns, while registered instantly on the BluVac, requires more than 10 seconds for the 552 to climb to the correct value. With that lag, combined with a resolution 100x lower than the BluVac, it's nearly impossible to visualize rapid changes in pressure due to evaporating moisture and/or refrigerant.

    I have also had problems on my 552 with drift on the low end (many hundreds of microns) due to temperature changes. Supposedly, Testo has fixed this problem, but I have no information as to how or how well.

    As usual, full disclosure: I am the manufacturer of the BluVac micron gauge. Please take that into account as you read the above.

  3. #16
    Join Date
    Aug 2009
    Location
    Maine
    Posts
    3,577
    Maybe yours isn't and mine is. I do not like the 552. It can't be trusted as far as I am concerned. As soon as I have a chance I will call Testo and see what, if anything can be done about it.

    Quote Originally Posted by jim bergmann View Post
    I have not noticed it being slow. I have run one side by side with a bluvac and they were neck and neck, less the resolution.

  4. #17
    Join Date
    May 2007
    Location
    Central NJ Area
    Posts
    865
    Quote Originally Posted by lytning View Post
    Maybe yours isn't and mine is. I do not like the 552. It can't be trusted as far as I am concerned. As soon as I have a chance I will call Testo and see what, if anything can be done about it.
    I had to change to my yellow jacket micron today because my brand new 552 would not go below 1060 microns and as soon as I switched micron gauges it droped below 500 microns. I just don't know what going on but plan on returning it for repair asap because I am not happy at all!!

  5. #18
    Join Date
    Oct 2013
    Posts
    6
    I bought a Testo 552 through TruTechtools.com. They were great and worked hard to make this a pleasant experience for me.

    The reasons to buy the 552 were reasonable accuracy (from the information available on line) and a broad range, from +82 psia to 0 microns.

    When connected to a vacuum source, at 36 microns, the 552 read 460 microns. The 36 microns where measured with a BluVac recently calibrated by the manufacturer (Thank you joeyd). The seller replaced the 552 twice, and the replacements read 320 microns at the same 36 microns. The three 552 gauges read the actual barometric pressure accurately.

    Reading the accuracy specifications from the manual downloaded from the Testo site, the specs supplied to the seller by Testo, the specs in the sales brochure and the specs in the owners manual that came with the instrument, they are different, and of course, the worst ones are the ones in the owners manual that comes with the gauge.

    I used to be a fan of the German Quality. Not in this case.

    I contacted Testo USA and Testo Germany to no avail. On the other hand, I recently got the Bluvac, "new" from ebay, but it had a couple of problems when I got it. I contacted Core Enterprises, the manufacturer of the Bluvac, and they allowed me bring the Bluvac to them for service and calibration. Joeyd determined that the meter had a manufacturing date of February 2011, but they took the meter in, serviced, updated and calibrated it for me at no charge. This in my book is outstanding customer service.

    Shame on Testo, kudos Accutools!!

  6. #19
    Join Date
    Aug 2009
    Location
    Maine
    Posts
    3,577
    I sent the Testo back in to the Company in, I think NJ. I paid the shipping. About 3 weeks later I got it back and it works. I use it as a back up for the BluVac so it doesn't get much use.

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event