Results 1 to 4 of 4
  1. #1
    Join Date
    Jun 2008
    Posts
    6

    Loud 'bang' on start up

    I have a Trane XL19i that was installed about 5 years ago, and yearly PM service performed in March. The compressor has always made what I consider a 'normal' noise - or momentary bang - as it is energized for start up. About a week ago however, this momentary bang has gotten much louder. Is this a known indication of some impending problem, or is my unit just aging...

  2. #2
    Join Date
    Aug 2012
    Posts
    2,326
    Would have to hear it. Might be liquid slugging but scrolls are known to have a centrifugal clang on start up.
    Trying not to be a Hack.

  3. #3
    Join Date
    Aug 2009
    Location
    Beatrice, NE
    Posts
    1,746
    19i's didn't have scrolls that I know of. They do have a heavy 3 pole contactor that is pretty noisy when it pulls in and can be kind of a "bang". I have never heard of them getting louder though. Usually as a contactor goes bad it will start buzzing or a loud hum when energized. The compressors have a cover on them so that should muffle any noise from them. I have seen where a spring will break inside the compressor and they will knock when they start, but never on a Trane compressor.

  4. #4
    Join Date
    Aug 2012
    Posts
    2,326
    Oh Sorry. My know it all attitude has reared it's ugly head again.
    Trying not to be a Hack.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event