Results 1 to 5 of 5
  1. #1
    Join Date
    Mar 2007
    Location
    NW Indiana
    Posts
    6

    HOT Shot and compressor seals.

    Has anyone heard of seals on a Trane 2A514 open compressor being wrecked by Hot Shot. City Compressor claims it does. This is after a year of use. The hot Shot is replacing R-12.

  2. #2
    Join Date
    May 2004
    Posts
    11,969
    Seal deterioration is infamous when using blends. Although some here, including me, are not big fans of HotSnot you will find that it will soften poly-base seals. There is no tech bulletin stating this but experience will guide your opinion. (in other words, if I had to prove it I couldn't) It may also have to do with POE.

    I.E. It's not very good for your quick connect hose gaskets either.

  3. #3
    Join Date
    Mar 2007
    Location
    NW Indiana
    Posts
    6
    No POE Mineral oil in there. Not a real fan of blends either MP-39 was in there 5 years prior not a problem till the seal blew. I'm thinking oil washed away from seal, could this be?

  4. #4
    Join Date
    May 2004
    Posts
    11,969

  5. #5
    Join Date
    Jan 2007
    Location
    Greensboro, NC
    Posts
    128

    Open Drive Seal Problems

    Quote Originally Posted by aeminc View Post
    Has anyone heard of seals on a Trane 2A514 open compressor being wrecked by Hot Shot. City Compressor claims it does. This is after a year of use. The hot Shot is replacing R-12.
    Carrier open drive 5H line seals turn to a soft black mess with hot shot and some other blends. Have you had any problems with copper-coating of the seal surface?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event