Page 2 of 2 FirstFirst 12
Results 14 to 19 of 19
  1. #14
    Join Date
    Jun 2013
    Location
    N. Canada
    Posts
    400
    Sorry, with this Galaxy phone I can't see post & type.
    PHM said 55 SL, which is 41SH.

    Won't let me edit my post.
    They'll have to extend that 15 min just for me.

  2. #15
    Join Date
    Aug 2002
    Location
    Southold.calm
    Posts
    5,616
    PHM
    Go to the Scotsman site and download I believe the C series manual.
    Single evap 2-400 model
    Duel evap 600 model
    Please pose comp model for ref type

  3. #16
    Join Date
    Aug 2002
    Location
    Southold.calm
    Posts
    5,616
    CM series.

    Is this the machine you have?
    Attached Images Attached Images

  4. #17
    Join Date
    Jun 2012
    Location
    Wisconsin
    Posts
    118
    If you call Scotsman tech line they will help you out if your stuck, the guys they have in house are great. Does this unit have a hot gas defrost on the evaporator? I have had those things let refrigerant leak by. Water temp is very critical to these units. Another thing I would check is the position of the sensing bulb for the power head, and if the sensing bulb is insulated. TXV should also be insulated. All of these items will influence the system

  5. #18
    Join Date
    Oct 2009
    Location
    Raleigh, NC
    Posts
    794
    Don't all ice machines have hot gas defrost? And, on a CM cuber, incoming water temp has no effect on the refrigeration cycle, other than warm incoming water extends the cycle time slightly, of course.

  6. #19
    Join Date
    Dec 2012
    Location
    Illinois
    Posts
    312
    Quote Originally Posted by Poodle Head Mikey View Post

    Looks like it's a little low on refrigerant with maybe a slightly clogged condenser. He did not have any R408 on the truck and the job's not critical enough to 'scramble' for. <g>

    What say you all? What's up with this puppy?
    I think your on it PHM!!

    I would probably put a clamp probe across that harvest valve to make sure it isn't bleeding, considering the age of this unit. (Early 90's?)

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event