Results 1 to 6 of 6
  1. #1
    Join Date
    Oct 2012
    Posts
    3,492

    Why don't my new units work???

    Brand new building. Originally had to go there in March because these brand new Lennox units wouldn't heat. Basically the installing contractor set the units on the curbs, hooked up the thermostats, and left. The fresh air hoods for the economizers weren't installed, the condensate drain ports had pipe plugs in them, this unit still has a piece of cardboard over the condenser, and about ten other things.

    The tenant is a national account, they purchased the units themselves and hired a local contractor to install. They called the installer and he said that he was all done with everything, the units where working fine, and that both units must have broken and someone from Lennox would have to come and warranty them.

    Installation problems aside, the main issue was that the blowers on the units where all spinning backwards, so the units had both tripped out on high limit. I'm told the installer gave a 90-Day warranty, so I didn't do any "work" to the units. I wrote down all the problems and told them to have the installer come back.


    So... Now that its warm out, I get a call that one of these units won't cool. Guess what, it still has the cardboard over the coil. The electrician came and changed phases so the blower rotation was right, but the hvac installer never came back to finish. I've seen his ad on craigslist, kind of scary.



    Name:  DSCF0873.jpg
Views: 893
Size:  24.7 KB

  2. #2
    Join Date
    Aug 2012
    Location
    willowick ,oh
    Posts
    261
    factory installed hail guard?

  3. #3
    Join Date
    Feb 2004
    Location
    michigan
    Posts
    677
    Good grief!

    "We bid install only. Their on the curbs and low voltage is hooked up. It costs extra for start up."

    We had a guy around here,no longer in buz, that did the same thing. Worst hacked up crap i ever saw. He was cheap tho.
    I am the "Wally". All others are meer imitations of the original.

  4. #4
    Join Date
    May 2004
    Location
    Salt Lake City/Tooele
    Posts
    2,454
    Then you have the guys that just chuck the screws that hold the condenser coil shipping guard in place and wonder why the condenser slab vibrates and forms leaks. Or they do not have there 5/16 with them and just man rip the guard out and mangle the fins.
    Probably still have a blower compartment full of accessory boxes and economizer panels.

  5. #5
    Join Date
    Oct 2012
    Posts
    3,492
    Quote Originally Posted by slctech View Post
    Probably still have a blower compartment full of accessory boxes and economizer panels.
    Yes, you are absolutely right. Big box sitting right next to the blower.

  6. #6
    Join Date
    Apr 2013
    Location
    Knoxville TN
    Posts
    53
    Theres a lot of those guys out there that just set a unit and leave and fail to tell the customer "oh my price was just to install the unit, you have to get a service guy to hook it up and start it. I knew a guy who had some duct/ac guys give him a price to install central air in his house. They set the units and ductwork then left. He had no clue that they would not run the lineset, power and t-stat.(he was vey pissed) He had to pay me to do it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event