Results 1 to 5 of 5
  1. #1

    RTAA-Phase reversal problem

    We have a RTAA that keeps tripping on “Phase Reversal Protection Loss”.
    We have replaced compressor contactors and compressor Cts. We have no indication of the building loosing a leg of power or anything. Any suggestions?
    I think we will install a voltage monitor on the incoming power.

    Thanks
    scepter

  2. #2
    Join Date
    Dec 2004
    Posts
    239
    Help us help you, what is the model of the rtaa. Is it across the line start or a wye delta starter? If it has a starter check it verry closely it may be hanging in transition.

  3. #3
    Join Date
    Aug 2006
    Location
    Mixing oil and fire with a big spoon.
    Posts
    4,247
    was this chiller built between 1 JAN 2001 and 1 SEP 2002? there was a problem that may/may not occur that had to do with the CT's.

    perform this check:
    1. make sure that all of your new CT's are actually the correct ones and that they are wired properly...they are polarity sensitive
    2. make sure that the controller is properly setup to read these CT's
    3. remove power. pull off the CT phoenix connector (green) that plugs the CT into the board. with a digital multimeter that has "diode check", read across the CT pins on the board (CT is unplugged at this point and power is off). it should read between 1.0 and 1.5. if it does not, then replace the board. if it is ok then reverse your leads on the same phoenix connector and check again (you are now checking it backwards). it should still read close to the same, but it does not need to read exactly the same. if either way does not read between 1.0 and 1.5, then the board needs to be replaced. if it does, then check the other CT's. you will probably find at least one of them bad.

    the above date reference had to do with some boards that were more sensitive to this condition.
    my 1st time jumping out of a plane...http://youtu.be/Kv38G0MHsGo

  4. #4
    Join Date
    Feb 2003
    Location
    Wichita Ks
    Posts
    1,457
    I had one do that once, it was 8 months old when the customer added power factor capacitors to it and it would get a phase reversal alarm about every two days. I unwired the capacitors and problem went away. I dont know what they ended up doing.

  5. #5
    Join Date
    Jun 2006
    Location
    Midwest
    Posts
    284
    The compressor modules that jayguy mentioned which could have diode problems have an -01 at the end of an extension number(sticker on module). Are you getting any other phase related diagnostics or just the "phase reversal protection loss"? How many circuits does this unit have and are all circuits shutting down from same diagnostic?
    It's All Good!!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event