Page 2 of 2 FirstFirst 12
Results 14 to 19 of 19
  1. #14
    Join Date
    May 2012
    Location
    Upper Michigan
    Posts
    3,589
    Quote Originally Posted by OldSchoolMech View Post
    I got a set of testo gauges in the service truck but i believe them to be out of whack. I also have no idea how to change refer etc. No one else in the company wants to use them or knows how.

    Do I just use ice water to make sure the temp sensors are right?

    Just use virgin refer to make sure the psi is right?

    If you found them on the ground what steps would you take to make sure they are 100%?

    I have nitro them and they don't leak. They are the lower model with sight glass not 100% of model but I know they are under $300 so lower end.
    Should have kept walking lol

  2. #15
    Quote Originally Posted by Joehvac25 View Post
    Should have kept walking lol
    Don't make me have to cross the Macinac, Joehvac25....my Testo's are very heavy

  3. #16
    Join Date
    May 2012
    Location
    Upper Michigan
    Posts
    3,589
    Quote Originally Posted by hvac5646 View Post
    Don't make me have to cross the Macinac, Joehvac25....my Testo are very heavy
    Ha ha I couldn't help myself!

  4. #17
    Join Date
    Feb 2012
    Location
    Toronto Canada
    Posts
    1,090
    So these gauges are the 557 LOL


    Does anyone got that PDF Thanks

  5. #18
    Join Date
    May 2009
    Location
    Cummins, GA
    Posts
    1,561

    PDF file for Testo gauges.

    Here you go:

    http://testo.co.kr/files/product/pdf/manual_e_testo%20557.pdf

    Referencing your comment above; The 557 does have an internal micron gauge.

    I'm not sure why it isn't coming up as a link. I will attempt to fix when I'm not on my phone.
    Last edited by Brent Ridley; 03-18-2013 at 07:00 PM.

  6. #19
    Quote Originally Posted by Brent Ridley View Post
    Here you go:

    http://testo.co.kr/files/product/pdf...esto%20557.pdf

    Referencing your comment above; The 557 does have an internal micron gauge.

    I'm not sure why it isn't coming up as a link. I will attempt to fix when I'm not on my phone.
    God! Good luck reading that manual. It is not written the way we normally see manuals written.

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event