Results 1 to 3 of 3

Thread: coldelite uc511

  1. #1
    Join Date
    May 2005
    Location
    greensboro nc
    Posts
    28

    coldelite uc511

    have acquired uc 511 softserve machine..... impressive machine,never used a coldelite before....it runs fine,makes product fast.when it makes and shuts down alls still well...when you pull the handle it tries to turn on beater motor but kicks off...it attempts 3 times before it trips the overload on the machine not the breaker....it's for sure the beater motor doing the humming...you can help turn the drive with your hand,or let it set awhile and it operates fine for a little while..i have a manual on it and it really protects the beater motor which electronically controls the hardness of the product by the amp draw.... the capacitor(starter) on the beater motor starts fine as long as the hardness isn't a finish hardness...this thing makes a finished product in 5 mins..it is 115v which is hard to believe with the size of the compressor and beater motor....i am planning to replace the start capactor first..motor is quiet and the drive turns good..granted it is snug when it cuts off at proper hardness...any ideas or guess's would be nice...thanks 1994 model

  2. #2
    Join Date
    May 2005
    Location
    greensboro nc
    Posts
    28
    i pulled the motor and drive assy and took to a motor repair shop,they could not fine anything wrong,they could load it and that did fine...disassembled drive that was ok.....the rta overload is set at 6amp max on the beater motor...i am putting it back together and check the amp load with meter.....the hom is set at "3" with a range of 1 to 11...the panel hom is set at 4.5 amp....i was in hopes somebody had dealt with a coldelite before,looking like nobody has ever seen on on this site

  3. #3
    Join Date
    May 2005
    Location
    greensboro nc
    Posts
    28
    tried to make ice cream sat.did ok for the first 30mins..then beater motor started kicking out again....black wire going to beater motor pulls 6 amp starting in the begining....when it messes up it's pulling 19 to 20 amp with fluke clamp meter.......tried last week looking for another motor itself..no one has it...the only thing i can find is a new motor and drive assy...price is very very high....this must be the downfall of older coldelite's...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event