Page 50 of 50 FirstFirst ... 404344454647484950
Results 638 to 644 of 644
  1. #638
    Join Date
    Sep 2005
    Location
    Atlanta GA area
    Posts
    37,349
    Post Likes
    There is a YJ unit out... does similar things... obviously not as good...

    There are threads on it somewhere at H-talk... do not remember the model # though...
    GA-HVAC-Tech

    Your comfort, Your way, Everyday!

  2. #639
    Join Date
    Jul 2010
    Location
    napping on the couch
    Posts
    9,348
    Post Likes
    Quote Originally Posted by AccurateHT View Post
    I’ve been using AKs exclusively since they were introduced and became the choice of so many on this forum.
    I’ve also been away from this forum for a few years, so imagine my shock and dismay when I attempted to purchase a fresh set of AKs for the cooling season!
    I have never grieved for the loss of a product before, but I’m really feeling this one.

    What the heck am I supposed to do now??
    Help....
    I picked up a nearly new looking set of AK900s on ebay for $200. The guy selling had zero ebay sales in his past so I think that's why people stayed away. But with PayPal protection, there really isn't any risk.

    I have a set but my clamps went bad. I'll have to pick up a set of clamps from Doug before they sell out. And yeah, I've checked the solder joints at the plug. They are fine. Low side temp started acting funny a couple months ago. Cutting in and out. Now it almost always is out but even when it comes back both temps are reading way off. The temp clamps I got in the ebay auction work fine in my original set.

    BTW, someone sold a new in the box set of AK900s for over $600 a month ago on ebay.

    Would have been a better investment a year ago to snatch up 10 AK900s than my Amazon stock.

  3. Likes ga-hvac-tech liked this post
  4. #640
    Join Date
    Jul 2010
    Location
    napping on the couch
    Posts
    9,348
    Post Likes
    Quote Originally Posted by ga-hvac-tech View Post
    There is a YJ unit out... does similar things... obviously not as good...

    There are threads on it somewhere at H-talk... do not remember the model # though...
    What are your thoughts on Testo gauges? There are a couple guys at work that picked them up and love them. Have they worked out the bugs that plagued them for years?

    BTW, I also picked up a set of Fieldpiece JL3KH6 Job Link Charge and Air Kit.

    Love them so far but I more often grab the DCs.

    Setting up the Fieldpiece vs just hitting an "on" button. Grabbing your phone to turning the screen back on because it sat for a minute. Etc. It's just a bit easier. Plus if you have to adjust the charge you are set up with the DCs. I have a "T" fitting and hose that I hook up to the FP if I have to, but it's just one more step.

  5. #641
    Join Date
    Jul 2011
    Location
    Arkansas
    Posts
    86
    Post Likes
    Try stripping back the insulation around where the wire enters the clamp and seeing if the wire is broke. Mine started giving funny readings on both sides. I knew where the poor connection was because if I moved the low side temp clamp wire around near the clamp it would come in and out. I ordered a new set of clamps but decided to try fixing the failed ones. As soon as I stripped it back it broke in two where the wire had become fatigued. I soldered it back together and covered it with shrink wrap. Been using them for about a year now with no trouble. So I still have an extra set of new clamps sitting on my shelf. Hoping I can get by with them for another 20 or so years😂. Or at least until the iDrsa comes out(wishful thinking)...

  6. Likes Brian8383 liked this post
  7. #642
    Join Date
    Nov 2008
    Location
    DFW,TX
    Posts
    3,600
    Post Likes
    Quote Originally Posted by clancyb424 View Post
    My AK's are holding/flashing any value over 100psi on the low side. Is there anyway to reset or clear this issue? If not, do I send them back to Canada? Am I out of luck? Love my Digi Cools...

    Thanks in advance,

    Brendan
    depending on the refer selected this is normal, if you hook them up when system is OFF as well the PSI will be over the max and it will flash..using Nitro purge also flash etc.. ive had mine for many many years, only issue with all DC sets are the clamp plugs they all pull pout or break..i gave up fixing them but still use my 1200s and ak900s for all my basic work..I have Iconnect for fine tuning diagnostics..

  8. #643
    Join Date
    Sep 2005
    Location
    Atlanta GA area
    Posts
    37,349
    Post Likes
    Quote Originally Posted by Brian8383 View Post
    What are your thoughts on Testo gauges? There are a couple guys at work that picked them up and love them. Have they worked out the bugs that plagued them for years?

    BTW, I also picked up a set of Fieldpiece JL3KH6 Job Link Charge and Air Kit.

    Love them so far but I more often grab the DCs.

    Setting up the Fieldpiece vs just hitting an "on" button. Grabbing your phone to turning the screen back on because it sat for a minute. Etc. It's just a bit easier. Plus if you have to adjust the charge you are set up with the DCs. I have a "T" fitting and hose that I hook up to the FP if I have to, but it's just one more step.
    B83... I really cannot make an evaluation on the Testo digital gauges... literally the only digitals I have owned...
    Are a DC1200 that was converted to a 1250...
    And a bunch of AK900's...
    The DC1250 has been retired and was sold to a guy for parts...

    Sorry I cannot help on this...
    GA-HVAC-Tech

    Your comfort, Your way, Everyday!

  9. #644
    Join Date
    Sep 2005
    Location
    Atlanta GA area
    Posts
    37,349
    Post Likes
    ON the DC temp clamps...

    If one looks at the handle... the side with the wire coming out of it, has a cover...
    Remove the cover and change the wire all the way from the clamp to the plug into the DC head...
    I did that a long time ago with a set of clamps... extended the life of the clamps considerably.

    Once in a while, the temp sensor (the silver tube in the business end of the clamp) fails...
    Not much one can do other than replace it.

    I HOPE Doug will come along at a point and give us information as to where to find that temp sensor...
    GA-HVAC-Tech

    Your comfort, Your way, Everyday!

Page 50 of 50 FirstFirst ... 404344454647484950

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Related Forums

Plumbing Talks | Contractor MagazineThe place where Electrical professionals meet.