Results 1 to 2 of 2
  1. #1

    Need help with 2 zone heating problem

    I have a 2 zone forced hot air furnace that is not working. The heat in our first zone works great but the 2nd zone does not heat properly. Both zones have identical honeywell digital thermostats and my furnace is an old carrier weathermate which I believe is from the mid 80's. When I turn the heat on in the 2nd zone I hear the fan come on but I just get cold air. If I set the fan to auto it never works but if I set it to on sometimes I get heat and sometimes I don't. When I do get heat it doesn't stay on, I don't know exactly how long it stays on for but I rarely make it to the set temperature.

    The furnace control board had some corrosion and the relay for zone 2 would spark when turned on an. I would get a 0 when tested with a voltimeter, zone 1 works fine and tests fine. I thought it might've been a bad board so I replaced the entire furnace control board but that didn't fix the problem. The new board does not have a clear cover over the relay so I don't know if it's still sparking and my friend took his voltimeter back so I can't test it.

    Does anyone have any thoughts on what could be causing this problem? My circuit breaker is fine, nothing is tripped. I would really appreciate any advice!

  2. #2
    Join Date
    Sep 2008
    Location
    Western PA
    Posts
    25,945

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event