I used to post regularly on this site about 8 years ago.... I'm a fridgie that should have retired by now. But here I am, still complaining about carrying too many tools at once onto a roof top, etc.

The question I'm posing, to me, seems to defy physics. As many of you will simply shake your head at your monitor as you sip on a Budweiser... I'm not far, shrugging my shoulders at my monitor also drinking my Budweiser.

I've repaired, installed, and trouble-shot many fireplaces, and ran into many anomolies. But this one seems to leave me short. I'll spell out the situation... and see what some of you cats think.

Josten Fireplace.

30,000 btu. Milivolt system. Originally had a gas valve (Nat Gas, @ 3.5" w.c.) No thermostat (jumpered out for the time being). NO fan assembly installed, although it's wired for that option. And as my own Mother spins in her grave over this.... NO Safeties factory installed, other than a pilot safety with a typical 'thermo-couple copper clad threaded termination to the body of the gas valve. No limit control or temp snap disc at all.

The problem:

The fireplace runs well, when we jumpered it out for a call for heat. It ran for almost 20 minutes to the second. Then both the gas valve shut off, as well as the pilot. Rendering the fireplace dormant.

1. The fire place was new off of a show room floor. Until we hooked it up, it had never been fired.
2. Gas pressure (Natural Gas) was again measured at 3.6" w.c.
3. Fire place was vented (concentric venting) exactly to manufacturer's specs. No wind or poor inlet air conditions were or are part of this problem on how the chimney/inlets are positioned outside the building.
4. During the 'burning process', the gas flame is the typical indigo blue, with no harsh burning characteristics, with only the most minimal yellow tipping to the flame on both 'Hi' and 'Lo' settings.
5. The pilot flame is 'text book' perfect on the Power-pile. 715 mv open... 460 mv in operation.
6. 20 minutes, the flame and pilot are burning magnificently until then, a click happens and both shut off like a 'limit' might do. (Remember, it's just the Powerpile, gas valve. with the TH terminals jumpered.
7. Tried a second brand new Power-pile, same result.
8. Tried a second thermo-couple, same result.
9. Suspected defective valve with all other easier options addressed... and replace it with a Robertshaw Fire Place gas valve, equally rated, only this one did not have the thermo-couple terminations on it... thus we
even eliminated one more safety (for testing purposes).
10. HOWEVER, the new Robershaw valve... bought us 10 more minutes.... so now it runs for 30 minutes before it 'clicks' off.
11. Tried running the FP with the glass front off - same result after 30 minutes.

I've considered elements like thermal drafts that might pull the pilot flame away or partially off of the Power pile. NOPE.

I've considered a shortage of primary air, or a non-supportive secondary air. Flame is perfect until it shuts off. NOPE.

Heck, I even went out and picked up more Budweiser! Didn't seem to help.

Any ideas?

Thanks guys 'n gals!

Ric