The stove was installed in the house in 2002. Has worked fine with the exception the auger bushing required replacement. Last weekend I had issues getting the auger to rotate but after a few resets it worked. This past weekend it would not rotate period! Folowing advice onlne I have taken the baffles, rear plates out and completely cleaned the interior back to the vent fan. None of the snap disks required resetting. I removed the auger and no blockage, vacuum tube is clean, vacuum port is clear - I can blow or draw a vacuum to the vacuum switch, pellet hopper full and the wiring is all connected. I checked voltages at each connection which matches values as stated online and in manual. I removed the control board cover and I see the red and green lights glow on top however the second green light directly on the board flashes on and off non stop. The door seal is worn but still makes good contact with the face of the stove. The lid under the fire pot moves back and forth however has a slight gap when closed. Last night I turned on the power and tossed in a few pellets manually. Everything worked (fans etc) however when the pellets burned away I tried to hit reset and nothing happened. Lots of lights flashing on the control board but reset switch not working. I called my local service cetner to speak with a tech but thought I would check here. This is a free standing stove with venting system installed by the local service center. From reading it appears the vacuum may be the problem but a bit lost now. FYI the auger is not receiving voltage from the module on start up during a ten minute check there after. The back stone plates were packed with crap. Could the vent pipe/fan be pugged? Thanks in advance for any thoughts or additional checks I can do.