Page 2 of 5 FirstFirst 12345 LastLast
Results 14 to 26 of 53
  1. #14
    Join Date
    Sep 2008
    Location
    Western PA
    Posts
    25,924
    Quote Originally Posted by TempcoDog View Post
    A motor up top too? Really hey? Haven't seen that yet. Yes one TXV. I never looked at the sight glass when I was on the roof as I just opened the electrical panel.
    Monday will have to get their staff to remove product and get the back panel off to check for another motor and see if any obstruction. dont think these have another motor. then also check if evidence of a leak starting from condenser.
    I've never seen the dual air curtain arrangement in a newer Hill Phoenix case.

    ALWAYS, ALWAYS, ALWAYS check the sightglass.

    ALWAYS!.

  2. #15
    Join Date
    Jun 2006
    Posts
    203
    That would have been the first thing i would of checked.

  3. #16
    Join Date
    Sep 2007
    Location
    NH
    Posts
    1,215
    How many defrosts? For how long?

  4. #17
    Join Date
    Aug 2012
    Posts
    21
    Thanks guys
    It's a hill Phoenix 05DMH12
    Off time defrost 6 times daily can't remember for how long. But it was fine for 3-4 years since installed new
    What I read they want 6-8 SH at bulb. I will first check sight!
    Yes low charge or tx problem now that I've read some info. And I now learned a tx was replaced in the case beside it last year. Coincidence?!

  5. #18
    Join Date
    Sep 2002
    Location
    Virginia
    Posts
    3,327


    Last thing I would admit ..... is I forgot to check sight glass

    LIE if you have to ; )

    First thing I do when walking up to a unit is check coil for cleanliness , then locate the SG

  6. #19
    Join Date
    Sep 2008
    Location
    Western PA
    Posts
    25,924
    Quote Originally Posted by TempcoDog View Post
    Thanks guys
    It's a hill Phoenix 05DMH12
    Off time defrost 6 times daily can't remember for how long. But it was fine for 3-4 years since installed new
    What I read they want 6-8 SH at bulb. I will first check sight!
    Yes low charge or tx problem now that I've read some info. And I now learned a tx was replaced in the case beside it last year. Coincidence?!
    http://www.hillphoenix.com/wp-conten...h.pdf?inline=1

    That ought to link you to the manual

  7. #20
    Join Date
    Dec 2008
    Location
    NW Iowa
    Posts
    128
    Quote Originally Posted by TempcoDog View Post
    Thanks guys
    It's a hill Phoenix 05DMH12
    Off time defrost 6 times daily can't remember for how long. But it was fine for 3-4 years since installed new
    What I read they want 6-8 SH at bulb. I will first check sight!
    Yes low charge or tx problem now that I've read some info. And I now learned a tx was replaced in the case beside it last year. Coincidence?!
    I have seen this before if the screens are gettting pluged, you may want to check that.

  8. #21
    Join Date
    Aug 2012
    Posts
    21
    what can I say snapper I'm a terrible lier!...I do know both coils are clean...screens..I'm assuming in the TX?

  9. #22
    Join Date
    Sep 2007
    Location
    NH
    Posts
    1,215
    Yep pump it down and check the screen after you check the sight glass...

    6 defrosts sounds like a lot for a hill Phoenix most of the newer ones I've installed are 4 defrosts for about 45 mins... But check your model with that link the JP put up.

  10. #23
    Join Date
    Sep 2007
    Location
    NH
    Posts
    1,215
    Never mind I see you posted your model, looks like 4 for 42 minutes.

  11. #24
    Join Date
    Aug 2012
    Posts
    21
    Pumped down and checked sight. Checked SH as per manufacturer instructions. Everything bang on. My mistake on the defrost. it is 4 times a day for 40 minutes off time. Removed product, shelves and panel. Heavy build up of ice on back of coil almost all he way but mainly the first half as I mentioned. Cleaned all that up. Stat has been acting erratic for awhile so we decided to change it. Boss said no at this time to checking screen. My guts with you chappa on the screen. Guess we will see what happens

  12. #25
    Join Date
    Sep 2008
    Location
    Western PA
    Posts
    25,924
    Quote Originally Posted by TempcoDog View Post
    Pumped down and checked sight. Checked SH as per manufacturer instructions. Everything bang on. My mistake on the defrost. it is 4 times a day for 40 minutes off time. Removed product, shelves and panel. Heavy build up of ice on back of coil almost all he way but mainly the first half as I mentioned. Cleaned all that up. Stat has been acting erratic for awhile so we decided to change it. Boss said no at this time to checking screen. My guts with you chappa on the screen. Guess we will see what happens


  13. #26
    Join Date
    Dec 2011
    Location
    Western Kentucky
    Posts
    44
    I'm confused!!

    What exactly was the purpose for pumping system down??

Page 2 of 5 FirstFirst 12345 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event