Results 1 to 6 of 6
  1. #1

    Trane gas heat not working

    Have a trane YSC102 reliatel that will not start combustion draft motor. Led on heat board steady on, when call for heat comes, led starts flashing and nothing happens. Jumped draft motor at board, motor will run. Replaced heat board, same problem. All limits are closed. Anyone had this problem? Thanks.

  2. #2
    Join Date
    Mar 2011
    Location
    North Carolina Piedmont Area
    Posts
    407
    Have you checked the out put of the IGN board.

    Is the run capacitor for the inducer draft motor ok?

    Have you verified that the motor windings are ok.

    The inducer draft motor may be a two speed. If so you will need to verify that the windings are not shorted.

    What is the serial No. of the unit? and have you checked if there are any service bulletins on this unit.

  3. #3
    Join Date
    Dec 2012
    Location
    columbus, OH
    Posts
    1,864
    is pressure switch open?

  4. #4
    Motor is single speed, 240v no capacitor. Motor operates if 240 v is applied.

    Will look at pressure switch! Board probly looks for that to be open on startup and if its stuck closed could be my problem.

  5. #5
    Join Date
    Dec 2012
    Location
    columbus, OH
    Posts
    1,864
    Keep us posted

  6. #6
    Got back to it today. It turned out to be a defective rtrm board. First time I have come across one of these bad out of the box.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event