Page 1 of 2 12 LastLast
Results 1 to 13 of 19
  1. #1
    Join Date
    Oct 2008
    Location
    Ventura, CA
    Posts
    40

    Inficon tech-mate

    Anyone having problems with the sensor on the Inficon Tech-Mate dectector?
    I bought one brand new about 6 months ago and used it once. Didnt work when i needed it a few months later. Had distributor send it
    Back to factory. Replaced sensor. Tried to use it again a few weeks later. Same problem. Is sensor breaking when unit is being subjected to vibration and/ or mild bumping around while in my truck? I keep in the case but maybe thats not protecting it enough?
    I cant horse around with keeping an important piece of test equipment on my truck that i cant count on.
    Thank you.

  2. #2
    Join Date
    Aug 2012
    Posts
    2,755
    My Experience has been put that ucker on the shelf and choose a different brand.

  3. #3
    Join Date
    Oct 2008
    Location
    Ventura, CA
    Posts
    40
    Quote Originally Posted by toocoolforschool View Post
    My Experience has been put that ucker on the shelf and choose a different brand.
    Thank you for your input.
    I better get a refund first. It wasnt cheap as to the price.
    Any brand thaf you've been happy with?

  4. #4
    Join Date
    Jun 2012
    Location
    Northeast
    Posts
    305
    We have about 4 in our shop all on guys trucks. Never had any problems. Maybe you should exchange it. Tell the supply house you want a new one.
    I have also been happy with CPS in the past.

  5. #5
    Join Date
    Oct 2008
    Location
    Fullerton
    Posts
    786
    Quote Originally Posted by kirwinjd View Post
    Anyone having problems with the sensor on the Inficon Tech-Mate dectector?
    I bought one brand new about 6 months ago and used it once. Didnt work when i needed it a few months later. Had distributor send it
    Back to factory. Replaced sensor. Tried to use it again a few weeks later. Same problem. Is sensor breaking when unit is being subjected to vibration and/ or mild bumping around while in my truck? I keep in the case but maybe thats not protecting it enough?
    I cant horse around with keeping an important piece of test equipment on my truck that i cant count on.
    Thank you.
    The Tech-mate is a heated diode leak detector. The diode starts decaying the moment it touches air and will decay faster as refrigerant hits it. Typically they'll last a few years but they do get less sensitive the more they are used or sitting around. This is how heat diodes work. They sense the burn of the sensor. If you don't use it all that often I'd recommend a leak detector with an infrared sensor. Both Inficon and Fieldpiece make one. The infrared sensor doesn't decay as it's only looking at how the refrigerant in the chamber is blocking light. Here's a video demoing the Fieldpiece Infrared.

    http://youtu.be/GA9A7cUWRHI

  6. #6
    Join Date
    Jul 2012
    Location
    Cincinnati ohio
    Posts
    252
    Quote Originally Posted by kirwinjd View Post
    Anyone having problems with the sensor on the Inficon Tech-Mate dectector?
    I bought one brand new about 6 months ago and used it once. Didnt work when i needed it a few months later. Had distributor send it
    Back to factory. Replaced sensor. Tried to use it again a few weeks later. Same problem. Is sensor breaking when unit is being subjected to vibration and/ or mild bumping around while in my truck? I keep in the case but maybe thats not protecting it enough?
    I cant horse around with keeping an important piece of test equipment on my truck that i cant count on.
    Thank you.
    I bought and used one for 1 season and only found 1 leak and tons of false positives. At the beginning of this past season I bought the field piece/ robin airs infrared detector, it costs twice as much as the tech mate but you will make money back with a reliable detector. You don't get false positives with a infrared detector and it works great with 410 unlike heated diode types.

  7. #7
    Join Date
    Nov 2011
    Location
    Charleston, Wv.
    Posts
    1,574
    I've got a tech mate. no problems here. we had another one at the shop, was beeping like crazy all the time, replaced sensor, and no problems out of it either. and it does sense 410. for the price, they do a good job.

    are you saying they sent it back to the factory for a sensor replacement? all you gotta do is pop the rubber cap off and replace it.....United stocks sensors.

    sounds you got a lemon.

  8. #8
    Join Date
    Jul 2012
    Location
    Cincinnati ohio
    Posts
    252
    Quote Originally Posted by 71CHOPS View Post
    all you gotta do is pop the rubber cap off and replace it.....United stocks sensors.

    sounds you got a lemon.
    I think there must have been a bad batch or something. We have had a lot of guys buy them in the last year and everyone had the same problem as you mentioned.

  9. #9
    Join Date
    Oct 2008
    Location
    Ventura, CA
    Posts
    40
    Thanks for your reply.
    I bought it from United but manager didnt know what was wrong with it and because it was under warranty, he sent it back. I suspected a bad sensor but he didnt have any in stock.

  10. #10
    Join Date
    Oct 2008
    Location
    Ventura, CA
    Posts
    40
    Thanks for your information. Ill pass it on to the manager at United Refrigeration.
    So frustrating (and costly) when you drive a long distance to fix a leak and finding out after you get there, your new leak detector doesnt work. Murphys Law at its finest.

  11. #11
    Join Date
    Aug 2012
    Posts
    2,755
    I was and am speaking from experience I have had nothing but problems with that leak detector so I bought a Bacharach, no problemos. Oh except when I lost the freaking sensor.

  12. #12
    Join Date
    Oct 2008
    Location
    Ventura, CA
    Posts
    40
    Thanks a lot for your information!
    Ill look into an infrared detector. Im so tired of false positives. I knew there had to be something better out there.

  13. #13
    Join Date
    Oct 2008
    Location
    Ventura, CA
    Posts
    40
    Thank you for your reply!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event