Page 2 of 2 FirstFirst 12
Results 14 to 19 of 19

Thread: Hiel H9mpd075

  1. #14
    Join Date
    Jul 2009
    Location
    Columbia, MD
    Posts
    3,787
    i would be looking real hard at the new bad inducer/wheel or secondary h/x

  2. #15
    Join Date
    Nov 2006
    Location
    Athens, Ohio
    Posts
    1,694
    Is the draft steady? Check with a manometer or draft gauge of your choice and post the readings.

    Someone else raised the question of a plugged heat exchanger but I would expect that would be a continuous problem rather than an intermittent one.

    I just converted a new ICP furnace to LP yesterday. It was the first time I had to put screws in the burners as directed in the instructions. It was a new model and a new style conversion kit. The conversion went smoothly though.

  3. #16
    Join Date
    Dec 2011
    Location
    missouri
    Posts
    169
    Could the manifold be cocked, or twisted, not allowing the orifices to point straight into the burners? Just a thought, let us know what you find!

  4. #17
    Join Date
    Jul 2010
    Location
    wisconsin
    Posts
    270
    Quote Originally Posted by hvacmontana View Post
    Has a new inducer assy. and the pr switch closes no problem.
    You were vague in your description of the series of events. Did you arrive at the house for a no heat call and find a bad inducer motor, and then have the burner issue, or was the burner issue present before you replaced the inducer? Also, check the colector box, as ive found three of these cracked in the past. I would install mixing screws in the burner venturi anyways to see if it changes anything.

  5. #18
    You are right I should have started at the begining. The inducer had been installed by another service tech (who is no longer doing service work), about a month before I was called. This was replaced the homeowner said because the old one seized. His call to me was because the furnace started making what he called a ratteling noise. When I tried the furnace I found the problem with the flame burning inside the venturi of the burners, this caused the door on the front of the burner compartment to vibrate until the flame jumped to front of the burners. Upon inspection I found 3 cracks in the collector box (Hiel calls it the transition assy), I sealed those with hi-temp RTV silicone with no change in the flame at startup. I ordered a new trans. assy and installed it, and checked the tubes of the secondary heat exchanger at that time, (all were clear). That brings me back to the points in my original post.

  6. #19
    Join Date
    Jul 2012
    Location
    Cincinnati ohio
    Posts
    252
    Have you checked the pressure in the combustion box? I remembered I had a similar issue on a mobile home furnace with a combustion air restriction.

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event